[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] connected but failed ping ?


  • Subject: Re: [Openvpn-users] connected but failed ping ?
  • From: Wahyu Cahyadi <wahyu@xxxxxxxxxxx>
  • Date: Tue, 22 Jan 2008 08:36:35 +0700

Lee wrote:
> ok, been trying to work this out on my own for weeks now, obviously I'm 
> missing something, or several things possibly. My b/g is this, want to 
> get 2 xp boxes on a tunnel, so far, just trying to get my laptop and 
> desktop to ping each other across the 2 dsl lines I have in my house. 
> Failing , but have come a long way from where I started, which would be 
> something similar to teaching the family dog to set up his own tunnel 
> with his friends. I'm not able to ping the 10.7.0.5, or 6 ip's. The WAN 
> ip's I can ping. . So  I'm not established, I don't think..lol..I've 
> turned off every firewall I have, of which there will be 3, (xp's, the 
> router, and the modem). Port Forwarded at the router and the modem, so 
> now what ??  :-) So, I'll post the config files, as well as the log from 
> the server side, some of it anyway, it just seems to repeat itself. I'm 
> sure there's something else ya'll would like to see as well, but I'm not 
> sure what atm..
> Thank you all, very much for your time.
> Lee
>
> the client side....
>
>
> # client
>  remote 71.31.57.161
>  dev tun
>   ifconfig  10.7.0.5  10.7.0.6 255.255.255.252
>  dev-node ATops
>  secret  key.txt
>  proto udp
>  resolv-retry infinite
>  nobind
>  persist-key
>  persist-tun
>  secret key.txt
>  comp-lzo
>  verb 4
>
>  the server side
>
>
>  port 1194
>  proto udp
>  remote 71.31.57.161-1149
>  dev tun
>  ifconfig 10.7.0.5  10.7.0.6
>  secret key.txt
>  keepalive 10 120
>  comp-lzo
>  persist-key
>  persist-tun
>  status openvpn-status.log
>  verb 3
>
>  config = 'ser ver.ovpn'
> 8   mode = 0
> 5   show_ciphers = DISABLED
> 2   show_digests = DISABLED
> 9   show_engines = DISABLED
> 6   genkey = DISABLED
> 3   key_pass_file = '[UNDEF]'
> 0   show_tls_ciphers = DISABLED
> 7   proto = 0
> 4   local = '[UNDEF]'
> 3   remote_list[0] = {'71.31.57.161-1149', 1194}
> 1   remote_random = DISABLED
> 8   local_port = 1194
> 5   remote_port = 1194
> 2   remote_float = DISABLED
> 8   ipchange = '[UNDEF]'
> 5   bind_local = DISABLED
> 2   dev = 'tun'
> 9   dev_type = '[UNDEF]'
> 6 NOTE: --mute triggered...
> 3 168 variation(s) on previous 20 message(s) suppressed by --mute
> 3 OpenVPN 2.0.9 Win32-MinGW [SSL] [LZO] built on Oct  1 2006
> 4 IMPORTANT: OpenVPN's default port number is now 1194, based on an 
> official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier 
> used 5000 as the default port.
> 4 Static Encrypt: Cipher 'BF-CBC' initialized with 128 bit key
> 4 Static Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
> 6 Static Decrypt: Cipher 'BF-CBC' initialized with 128 bit key
> 7 Static Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
> 1 LZO compression initialized
> 5 TAP-WIN32 device [ATops] opened: 
> \\.\Global\{774CE1E5-1341-47FF-841D-80B90D72EEF5}.tap
> 0 TAP-Win32 Driver Version 8.1
> 0 TAP-Win32 MTU=1500
> 6 Notified TAP-Win32 driver to set a DHCP IP/netmask of 
> 10.7.0.5/255.255.255.252 on interface 
> {774CE1E5-1341-47FF-841D-80B90D72EEF5} [DHCP-serv: 10.7.0.6, lease-time: 
> 31536000]
> 9 Successful ARP Flush on interface [2] 
> {774CE1E5-1341-47FF-841D-80B90D72EEF5}
> 2 Data Channel MTU parms [ L:1545 D:1450 EF:45 EB:135 ET:0 EL:0 AF:3/1 ]
> 9 Local Options String: 'V4,dev-type tun,link-mtu 1545,tun-mtu 
> 1500,proto UDPv4,ifconfig 10.7.0.6 10.7.0.5,comp-lzo,cipher BF-CBC,auth 
> SHA1,keysize 128,secret'
> 9 Expected Remote Options String: 'V4,dev-type tun,link-mtu 1545,tun-mtu 
> 1500,proto UDPv4,ifconfig 10.7.0.5 10.7.0.6,comp-lzo,cipher BF-CBC,auth 
> SHA1,keysize 128,secret'
> 1 Local Options hash (VER=V4): '981d55a0'
> 6 Expected Remote Options hash (VER=V4): '812fd57b'
> 2 Socket Buffers: R=[8192->8192] S=[8192->8192]
> 0 UDPv4 link local: [undef]
> 8 UDPv4 link remote: 71.31.57.161:1194
> 2 Inactivity timeout (--ping-restart), restarting
> 6 TCP/UDP: Closing socket
> 9 SIGUSR1[soft,ping-restart] received, process restarting
> 1 Restart pause, 2 second(s)
> 6 IMPORTANT: OpenVPN's default port number is now 1194, based on an 
> official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier 
> used 5000 as the default port.
> 6 Re-using pre-shared static key
> 0 LZO compression initialized
> 8 Preserving previous TUN/TAP instance: ATops
> 9 Data Channel MTU parms [ L:1545 D:1450 EF:45 EB:135 ET:0 EL:0 AF:3/1 ]
> 6 Local Options String: 'V4,dev-type tun,link-mtu 1545,tun-mtu 
> 1500,proto UDPv4,ifconfig 10.7.0.6 10.7.0.5,comp-lzo,cipher BF-CBC,auth 
> SHA1,keysize 128,secret'
> 7 Expected Remote Options String: 'V4,dev-type tun,link-mtu 1545,tun-mtu 
> 1500,proto UDPv4,ifconfig 10.7.0.5 10.7.0.6,comp-lzo,cipher BF-CBC,auth 
> SHA1,keysize 128,secret'
> 9 Local Options hash (VER=V4): '981d55a0'
> 4 Expected Remote Options hash (VER=V4): '812fd57b'
> 6 Socket Buffers: R=[8192->8192] S=[8192->8192]
> 9 UDPv4 link local: [undef]
> 4 UDPv4 link remote: 71.31.57.161:1194
> 5 Inactivity timeout (--ping-restart), restarting
> 0 TCP/UDP: Closing socket
>   
I think you should try first the easiest way of openvpn configuration 
using OpenVPN Static Key
read this: http://openvpn.net/static.html

--
wahyu
http://veryeasytutorial.blogspot.com/

____________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users