[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

[Openvpn-users] Mac OS X 10.4 tap Problem


  • Subject: [Openvpn-users] Mac OS X 10.4 tap Problem
  • From: Christopher Mills <millsspam@xxxxxxxxxxx>
  • Date: Sun, 20 Jan 2008 16:22:50 -0700

Problem:

   1. I am running Mac OS X 10.4.11
   2. I am running Tunnelblick-Universal-3.0b6.dmg.
   3. My tap device doesn't appear under ifconfig
   4. The problem appears to be with the tun/tap kernel extension.

For reference, the problem is manifest under OpenVPN with the following 
log results (verb 8):
                     ...
Sun 01/20/08 12:29 PM: TUN/TAP device /dev/tap0 opened
Sun 01/20/08 12:29 PM: /sbin/ifconfig tap delete
Sun 01/20/08 12:29 PM: SYSTEM[0] '/sbin/ifconfig tap delete'
Sun 01/20/08 12:29 PM: SYSTEM return=256
Sun 01/20/08 12:29 PM: NOTE: Tried to delete pre-existing tun/tap 
instance -- No Problem if failure
Sun 01/20/08 12:29 PM: /sbin/ifconfig tap 192.168.93.20 netmask 
255.255.255.0 mtu 1500 up
Sun 01/20/08 12:29 PM: SYSTEM[2] '/sbin/ifconfig tap 192.168.93.20 
netmask 255.255.255.0 mtu 1500 up'
Sun 01/20/08 12:29 PM: SYSTEM return=256
Sun 01/20/08 12:29 PM: Mac OS X ifconfig failed: shell command exited 
with error status: 1

Particulars:

   1. I run kextload and unload manually as a superuser-- independent of
      OpenVPN-- and the tap0 interface still doesn't appear (same
      problem) when then running OpenVPN.
   2. The above log suggests OpenVPN thinks it sucessfully opened the
      tap0 interface.
   3. I assume that the tap0 interface should show up in ifconfig after
      being successfully opened by OpenVPN.
   4. I don't know offhand how to independently test opening a tap
      interface.
   5. I find know messages in the system logs reporting any errors of
      any kind other than the OpenVPN logging itself.

Anybody have any thoughts on what might be going on?


Config file for reference:

remote x.x.x.x

dev tap

#dev-node TAP0
dev-node /dev/tap0

ifconfig 192.168.93.20 255.255.255.0

secret keys/key.txt
port 4550

tun-mtu 1500
tun-mtu-extra 32
mssfix 1450
key-method 2

#comp-lzo
______________________
OpenVPN mailing lists
https://lists.sourceforge.net/lists/listinfo/openvpn-users