[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] using openvpn client 2.1 with openvpn server 2.0x


  • Subject: Re: [Openvpn-users] using openvpn client 2.1 with openvpn server 2.0x
  • From: Oscar Knight <knightod@xxxxxxxxxxxx>
  • Date: Thu, 17 Jan 2008 08:28:10 -0500

Hello John,

John Kuiper wrote:
> Hello,
> 
> All my pc's are running perfectly with XP en openvpn.
> But now I have one laptop with Vista Business.
> 
> There is a connection, but the remote route will not bet connected
> ( route addition failed using CreateIpForwardEntry: ......)
> 
> I read that's better to use openvpn 2.1 instead.
> Can I run openvpn 2.1 on the client and openvpn 2.0x on the server.

We are using OpenVPN 2.09 on our server running OpenBSD.  We have
windows clients (mostly XP) running both 2.09 and 2.1rc4.  We have some
Vista clients running 2.1rc4.

Your route addition problem is common.  You'll need to set one or more 
items to run as administrator.  After you install 2.1rc4 there will be a 
icon for the GUI on the desktop.  Right click that icon, select 
properties.  One of the tabs has a check box near the bottom that's for 
"run as administrator", check that box.  Click OK.

Start the GUI and then connect.  Check the status for failed routes.

Hope this helps,
odk
-- 
Oscar D. Knight                           knightod at appstate dot edu
ITS                                                Voice: 828-262-6946
Appalachian State University, Boone, NC 28608        FAX: 828-262-2236

____________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users