[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Web openvpn.net

Re: [Openvpn-users] help with setting up first vpn, some urgency!

  • Subject: Re: [Openvpn-users] help with setting up first vpn, some urgency!
  • From: "Dave" <dmehler26@xxxxxxxxxx>
  • Date: Fri, 21 Dec 2007 09:59:55 -0500

    Actually thanks for that. That does help. I was under the impression 
that windows shared folders only worked with tap.
    Setting up tun actually does get me further, i can at least connect and 
i see the route going to the client, but that's about it.
    If anyone remote to me can help i'll give some keys and hopefully get 
this going.

----- Original Message ----- 
From: "David Balazic" <David.Balazic@xxxxxxxxxxxxxxxxxx>
To: "Dave" <dmehler26@xxxxxxxxxx>; <openvpn-users@xxxxxxxxxxxxxxxxxxxxx>
Sent: Friday, December 21, 2007 9:34 AM
Subject: RE: [Openvpn-users] help with setting up first vpn, some urgency!

OK, I will be short:

It is a mistery for me , why people waste their time setting up TAP, when 
TUN is so much simpler.
And it works. Including windows shared folders.




From: openvpn-users-bounces@xxxxxxxxxxxxxxxxxxxxx on behalf of Dave
Sent: čet 20-dec-07 18:04
To: openvpn-users@xxxxxxxxxxxxxxxxxxxxx
Subject: [Openvpn-users] help with setting up first vpn, some urgency!

    I need some assistance with setting up my first vpn and there is some
urgency in it as i'm going to be going out of town for the holidays and am
going to need it.
    I've read the docs and the book, and i've got keys generated and i can
connect from a remote client, in routed moee. If i try in bridge mode i get
"Can not connect to client connection failed" msg. The bridge mode
connection was atempted from an xp home client.
    My goal is to be able to set up a vpn remotely, remote in, and access my
samba shares, and my test and development web server as if i was here.
    The problem is when i connect i can ping, but i don't get anything back.
A tcpdump on the interface on the lan pc where the vpn server is shows the
packets coming in but not going out. Trying to query my lan's local
nameserver times out, that can't be located.
    Let me give you some information. I'm going to be using either a roaming
laptop or a fixed desktop box, both of which will be remote to my network.
Let's say for the sake of example that the laptop will have ip of
and the desktop will have the ip of My internal lan ip range is and the vpn server, i've tried this twice will either be on a
Centos box or a FreeBSD box, at either .3 or .4 in that range. The dns
server/lan gateway box is .254. My vpn range is in routed mode,
if i can get bridge mode going i'll put it in my lan range.
    As i said i've tried both, i can connect in routed mode, get the error
about connecting to client failed in bridge. The samba server and the test
web server are both on the same box, depending on which box the vpn server
is on it might or might not be the same machine depending on which is easier
to set up.
    If anyone can help i can create accounts where needed with sudo and i
can supply client keys.
    Any additional information let me know.
    As i said there is some urgency as i can only test this remotely and i
won't be remote until i leave, if it doesn't work i'm outa luck.
    Any help much appreciated.

Openvpn-users mailing list

Openvpn-users mailing list