[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

[Openvpn-users] RV: help with setting up first vpn, some urgency!


  • Subject: [Openvpn-users] RV: help with setting up first vpn, some urgency!
  • From: "Damian Rivas" <damian@xxxxxxxxxx>
  • Date: Thu, 20 Dec 2007 17:01:05 -0300

If the data enters but doesn't return it is probably a Firewall issue.
Have you checked that you are letting traffic out on the tun interface?
Send to the list your firewall rules for the VPN and lets check them
out.

Regards.-
Damian

-----Mensaje original-----
De: openvpn-users-bounces@xxxxxxxxxxxxxxxxxxxxx
[mailto:openvpn-users-bounces@xxxxxxxxxxxxxxxxxxxxx] En nombre de Dave
Enviado el: Jueves, 20 de Diciembre de 2007 02:05 p.m.
Para: openvpn-users@xxxxxxxxxxxxxxxxxxxxx
Asunto: [Openvpn-users] help with setting up first vpn, some urgency!


Hello,
    I need some assistance with setting up my first vpn and there is
some 
urgency in it as i'm going to be going out of town for the holidays and
am 
going to need it.
    I've read the docs and the book, and i've got keys generated and i
can 
connect from a remote client, in routed moee. If i try in bridge mode i
get 
"Can not connect to client connection failed" msg. The bridge mode 
connection was atempted from an xp home client.
    My goal is to be able to set up a vpn remotely, remote in, and
access my 
samba shares, and my test and development web server as if i was here.
    The problem is when i connect i can ping, but i don't get anything
back. 
A tcpdump on the interface on the lan pc where the vpn server is shows
the 
packets coming in but not going out. Trying to query my lan's local 
nameserver times out, that can't be located.
    Let me give you some information. I'm going to be using either a
roaming 
laptop or a fixed desktop box, both of which will be remote to my
network. 
Let's say for the sake of example that the laptop will have ip of
2.3.4.5 
and the desktop will have the ip of 3.4.5.6. My internal lan ip range is

192.168.0.0/24 and the vpn server, i've tried this twice will either be
on a 
Centos box or a FreeBSD box, at either .3 or .4 in that range. The dns 
server/lan gateway box is .254. My vpn range is 10.8.0.0/24 in routed
mode, 
if i can get bridge mode going i'll put it in my lan range.
    As i said i've tried both, i can connect in routed mode, get the
error 
about connecting to client failed in bridge. The samba server and the
test 
web server are both on the same box, depending on which box the vpn
server 
is on it might or might not be the same machine depending on which is
easier 
to set up.
    If anyone can help i can create accounts where needed with sudo and
i 
can supply client keys.
    Any additional information let me know.
    As i said there is some urgency as i can only test this remotely and
i 
won't be remote until i leave, if it doesn't work i'm outa luck.
    Any help much appreciated.
Dave.

______________________
OpenVPN mailing lists
https://lists.sourceforge.net/lists/listinfo/openvpn-users