[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Web openvpn.net

[Openvpn-users] Log into a domain through VPN

  • Subject: [Openvpn-users] Log into a domain through VPN
  • From: "Damian Rivas" <damian@xxxxxxxxxx>
  • Date: Mon, 3 Dec 2007 10:58:15 -0300

Title: Mensaje
Hi people, I'm having the following problem:
I have a working VPN connection but I cannot login to a Domain. I put the OpenVPN Client as a service on the Windows remote machines(who are the VPN clients of the organization) and tried to log inside the domain with no success. The VPN cannot find the domain name.
I think the clue is that when I try to ping to a LAN machine by its DNS suffix from the VPN client, it fails (but it pings to a machine by its IP). So the problem is certainly with the DNS, which somehow although I'm pushing them to the client are not working properly.
these are the pushing options on my server config file: 
push "route"
push "dhcp-option DNS"

where: is the entire organization subnet is the main Domain Controller, and the primary internal DNS. It is a Windows 2k3, running active directory.
I tried to push the gateway but the results where the same, somehow the DNS are not working, or at least they cannot resolv the names correctly through the VPN. I think once this issue is solved I would be able to log into the domain.
Thanks in advance!