[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Web openvpn.net

[Openvpn-users] Tap driver does not run on Windows 2k (code 31)

  • Subject: [Openvpn-users] Tap driver does not run on Windows 2k (code 31)
  • From: Todor Boev <t.boev@xxxxxxxxxx>
  • Date: Fri, 30 Nov 2007 14:05:18 +0200

Hello all,
I installed OpenVPN on windows 2k sp4. During the installation tapinstall.exe failed with status 2 like this:

tapinstall.exe failed
tapinstall install returned: 2
tapinstall cumulative status: 2

The archives of this mail list suggest to check if the RunOnce key is in my registry. I checked and the key was there as expected. When I checked the hardware manager I found a "TAP-Win32 Adapter V8" device under the network adapters node. It had an exclamation mark on it noting there's a problem with this device. I ran the Add/Remove Hardware troubleshooting wizard for that device and it reported the problem to be:

This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

Which than the wizard says means:

This device depends on another device that is not functioning correctly.

However the hardware manager does not indicate any problems with none of my other devices. Nor could I find out what that other mystery device is. I rebooted to make sure the device setup is completed (this is windows after all) but the problem remains exactly the same.

Next I tried to remove and add the device multiple times with the provided scripts. Both scripts reported failures although the TAP device did appear and disappear from the device manager tree. Next I tried installing manually from the command prompt using "tapinstall OemWin2k.inf tap0801" and it failed as well although the TAP device appeared in under network adapters.

Finally I tried simply to ignore the error and tried to establish a TUN connection to my linux machine, which acts as the vpn server. The connection passed the authentication and routing stages and than windows fell on its face with a message that it could not find any TAP devices on this machine. Indeed there were no vpn connections listed under the Network Connections list.

Finally I tried to establish the connection while the OpenVPN service is running - made no difference.

Please help - I completely ran out of ideas and have tried everything I could find on the net.

fn:Todor Boev

Openvpn-users mailing list