[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Web openvpn.net

Re: [Openvpn-users] setting up TAP

  • Subject: Re: [Openvpn-users] setting up TAP
  • From: "Tom Cook" <tom.k.cook@xxxxxxxxx>
  • Date: Fri, 26 Oct 2007 09:59:41 +0930

On 10/26/07, Jeff - <unix_core@xxxxxxxxxxxxx> wrote:
I'm having many unsolvable problems using tun so I thought I'd try tap.

After I run the bridge_start I see br0, eth0, and tap0

The br0 now has an IP address but the other 2 do not.  Is this normal?

Yep, that's right.  br0 is a virtual ethernet interface that combines the eth0 and tap0 physical interfaces.  Only br0 gets an IP address.

When I run OpenVPN on the server and try to connect to it I get an error writing to UPDv4.  Network is unreachable (code 101)

I am no expert here, but it sounds as though you are trying to route the VPN transport traffic over the VPN itself.  Try connecting and then look at the output of 'route -n'.  Check that there is not a default route that puts traffic over the VPN.  If there is, figure out where it is coming from and disable it.

What am I missing?

Also on reboot I don't have the br0 or tap0 anymore.  Do I have to manually get bridge_start to run on bootup?  I'm using debian 4.0

I do this on a debian 4 system.  In /etc/network/interfaces I have this stanza:

auto br0
iface br0 inet static
        bridge_ports eth1

This means:  Set up a bridge interface br0 with the static address and make it incorporate the eth1 physical interface.  The 'auto br0' line means to bring it up when the system boots.  I then use a script run with the --up option to openvpn to execute 'brctl addif br0 tap0' so that the tap0 interface is added to the bridge when it becomes present (ie. when the VPN is up).