[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] server won't start, no output


  • Subject: Re: [Openvpn-users] server won't start, no output
  • From: Bart van Heukelom <mail@xxxxxxxxxxxxxxxxxx>
  • Date: Tue, 02 Oct 2007 20:55:35 +0200

i've somehow managed to fix things. i can now start and connect to the server. however, i cannot ping it from the client
here are my config files:
server: http://www.the3rdage.net/files/2745/heukvpn.conf
client: http://www.the3rdage.net/files/2745/client.ovpn

Andrew Guenther schreef:


Andrew Guenther
ACE Technology Group
610 640 4223 x2

On Oct 1, 2007, at 5:02 PM, Bart van Heukelom <mail@xxxxxxxxxxxxxxxxxx> wrote:

I would like to create a VPN connection between my remote windows laptop
and linux (debian) home server. i've downloaded and installed openvpn
with apt-get, and configured it correctly (AFAIK). however, the server
won't start

if i run *openvpn <configfile>* there's no output and the process exits
immediately, while there should be something like this

   quote:
   Sun Feb 6 20:46:38 2005 OpenVPN 2.0_rc12 i686-suse-linux [SSL] [LZO]
   [EPOLL] built on Feb 5 2005
   Sun Feb 6 20:46:38 2005 Diffie-Hellman initialized with 1024 bit key
   Sun Feb 6 20:46:38 2005 TLS-Auth MTU parms [ L:1542 D:138 EF:38 EB:0
   ET:0 EL:0 ]
   Sun Feb 6 20:46:38 2005 TUN/TAP device tun1 opened
   Sun Feb 6 20:46:38 2005 /sbin/ifconfig tun1 10.8.0.1 pointopoint
   10.8.0.2 mtu 1500
   Sun Feb 6 20:46:38 2005 /sbin/route add -net 10.8.0.0 netmask
   255.255.255.0 gw 10.8.0.2
   Sun Feb 6 20:46:38 2005 Data Channel MTU parms [ L:1542 D:1450 EF:42
   EB:23 ET:0 EL:0 AF:3/1 ]
   Sun Feb 6 20:46:38 2005 UDPv4 link local (bound): [undef]:1194
   Sun Feb 6 20:46:38 2005 UDPv4 link remote: [undef]
   Sun Feb 6 20:46:38 2005 MULTI: multi_init called, r=256 v=256
   Sun Feb 6 20:46:38 2005 IFCONFIG POOL: base=10.8.0.4 size=62
   Sun Feb 6 20:46:38 2005 IFCONFIG POOL LIST
   Sun Feb 6 20:46:38 2005 Initialization Sequence Completed

if i run */etc/init.d/openvpn start* i get

   quote:
   Starting virtual private network daemon: heukvpn(FAILED).

a very non-descriptive error. what can i be doing wrong?
i've already tried openvpn --verb 11 --config <configfile> but nothing
changes

Bart

begin:vcard fn:Bart van Heukelom n:van Heukelom;Bart adr:;;;;;;The Netherlands email;internet:mail@xxxxxxxxxxxxxxxxxx x-mozilla-html:TRUE url:http://www.bartvanheukelom.nl version:2.1 end:vcard
-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users


Bart,

Try your /etc/init.d/openvpn start again, then run this command:

grep ovpn /var/log/syslog

Of all the output that gives you, your error should be towards the bottom.

To run openvpn manually try this:
openvpn --cd /etc/openvpn --config /etc/openvpn/server.conf


Andrew



begin:vcard
fn:Bart van Heukelom
n:van Heukelom;Bart
adr:;;;;;;The Netherlands
email;internet:mail@xxxxxxxxxxxxxxxxxx
x-mozilla-html:TRUE
url:http://www.bartvanheukelom.nl
version:2.1
end:vcard

_______________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users