[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Web openvpn.net

[Openvpn-users] bridging, strange issue

  • Subject: [Openvpn-users] bridging, strange issue
  • From: "skuns@xxxxx" <skuns@xxxxx>
  • Date: Sat, 08 Sep 2007 23:04:36 +0400

Hi there. I have following bridge configuration:

   debian linux box. openvpn server - A, internal network
x.x.x.x - A, internet network
   Adsl modem. with NAT
    client. debian linuxbox

After connection succesfull initiated, i cannot ping from client nor A, 
not network 37.0/24. And vise versa. Both host return destination host 
Client got an address but can't obtain mac address for 
server, arp -a show a record (incomplete)   tap0. Server 
A has same incomplete record for client address. Arp request from client 
transfered to tap0, but looks that packet nether reach server. Server 
tap0 interface has a some broadcast traffic, that never reach client 
(tcpdump capture nothing). During arp request, debug show lines like 
WrWrWr (lower case 'r'). Keeapilve packets running normally (looks like 
WRWRWR chars in debug), and routed tunnel (same servers, routed tunnel 
setup) works fine. Both host has empty iptables with accept as default 

config for server:
port 1194
proto tcp
dev tap
ca /etc/openvpn/easy-rsa/keys/ca.crt
cert /etc/openvpn/easy-rsa/keys/server.crt
dh /etc/openvpn/easy-rsa/keys/dh1024.pem
ifconfig-pool-persist ipp.txt
push "route"
keepalive 10 120
user nobody
group nogroup
status openvpn-status.log
verb 4

client config

dev tap
proto tcp
remote x.x.x.x 1194
resolv-retry infinite
ca /etc/openvpn/keys/ca.crt
cert /etc/openvpn/keys/cobalt.crt
key /etc/openvpn/keys/cobalt.key
verb 5

route table for client:

Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt 
Iface   UG        0 0          0 
tap0   U         0 0          0 
tap0   U         0 0          0 
eth0         UG        0 0          0 
At last, i tried change server from debian to suse, remove server-bridge 
and add 'config' directive, change client to winxp  - all same result. 
All looks like that i did a fundamental error on server side, but can't 
determine where is it. Please help, i'm about to going mad.

Openvpn-users mailing list