[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] Vista, Samba, WINS server - browse lists not working in same workgroup across VPN


  • Subject: Re: [Openvpn-users] Vista, Samba, WINS server - browse lists not working in same workgroup across VPN
  • From: "David Balazic" <David.Balazic@xxxxxxxxxxxxxxxxxx>
  • Date: Tue, 21 Aug 2007 10:03:14 +0200

Hi!
 
I'm 95% sure this is not a OpenVPN issue, but just how Windows Network Sharing works.
If in doubt whether it is a Vista issue, just try WinXP ;-)
 
I think Windows displays by default only hosts found on the same subnet.
Try entering the WINS server into the netwrok adapter properties (on Vista).
Manually or via DHCP.
 
Regards,
David
 

________________________________

From: openvpn-users-bounces@xxxxxxxxxxxxxxxxxxxxx on behalf of Florin Andrei
Sent: Mon 20-Aug-07 20:35
To: openvpn-users@xxxxxxxxxxxxxxxxxxxxx
Subject: [Openvpn-users] Vista, Samba, WINS server - browse lists not working in same workgroup across VPN



Using OpenVPN-2.1 on a CentOS 5 server. One client is Windows Vista.
There's also a local network behind the CentOS server, with a variety of
systems, including an Ubuntu 7.04 workstation.

The OpenVPN clients are using a 192.168.x private range different from
the one used on the local network (routed, not bridged VPN). However,
all systems are part of the same workgroup, with the CentOS server
acting as a WINS server for everything. CentOS is also a nameserver for
all these networks.

Direct and reverse DNS works properly on all networks, including VPN.
The local network and the VPN addresses are on different DNS domains.

When I boot Vista, it connects to OpenVPN automatically (run as service).

The problem is, when I open the Network window on Vista ("network
neighborhood" used to be called on older Windows versions), I do not see
the CentOS server and the Ubuntu workstation, even though they are part
of the same Windows workgroup and WINS seems to work properly. All I see
is the Vista system itself, but nothing else is listed automatically.

If I enter \\the-Ubuntu-workstations-name directly in Explorer on Vista,
it does see the workstation and all its shares, I can upload/download
files just fine. But it does not appear automatically in the "network
neighborhood" list (or whatever is the proper name on Vista) no matter what.

I tried a variety of things, I tweaked smb.conf on the server and on the
workstation, I played with Windows-specific options in the .ovpn file on
Vista, etc. The list of things I tried is too long to put it here.
Nothing seems to help.

I'm kind of stumped. Is there a "secret recipe" to make this work? Some
kind of algorithm or checklist to go through?
I'm not even sure it's an OpenVPN issue. It might be it, or it might be
Samba, or DNS, or Vista, or something else. I'm just kind of shooting in
the dark.

--
Florin Andrei

http://florin.myip.org/

-------------------------------------------------------------------------______________________
OpenVPN mailing lists
https://lists.sourceforge.net/lists/listinfo/openvpn-users


<<winmail.dat>>

_______________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users