[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

[Openvpn-users] Today (8/14/2007) Microsoft update broke all Windows OpenVPN setups!


  • Subject: [Openvpn-users] Today (8/14/2007) Microsoft update broke all Windows OpenVPN setups!
  • From: Andrew Scherpbier <andrew@xxxxxxxxxxxxx>
  • Date: Tue, 14 Aug 2007 17:48:28 -0700

Hi,
I've been getting bombarded with complaints from my remote users that 
their VPN no longer works.
The setup:

Debian GW with OpenVPN 2.0.9-8
Windows XPSP2 clients use OpenVPNGui 1.0.3 (with OpenVPN 2.0.9)

We've been using this setup for a long time, but today things started 
breaking, but only for windows users.
Mac and Linux users are still connected, no problem.

The symptoms:
On the windows machines, the route to the office network doesn't get 
installed when OpenVPN connects.

Since this started happening this morning, and I've had several windows 
boxen get windows updates, my suspicions when there.  Indeed, after a 
system restore to *before* this morning's updates, the VPN works like a 
charm.

I have not been able to figure out which update is the culprit, but I 
know it has to be one of these:

KB936782
KB936021
KB938127
KB938828
KB921503
KB938829
KB937143

Of those the KB938828 looks the most mysterious.

So, has anyone else seen this?
Does anyone know which specific update causes the problem?
Does anyone know any other workaround?

--Andrew Scherpbier

____________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users