[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] 2.1rc vista client and 2.0.9 linux server


  • Subject: Re: [Openvpn-users] 2.1rc vista client and 2.0.9 linux server
  • From: Josh Cepek <josh.cepek@xxxxxxx>
  • Date: Sun, 29 Jul 2007 23:50:13 -0500
  • Openpgp: id=2E5A5127
  • Z-usanet-msgid: XID741LgdeYu0036X36

mbneto wrote:
Hi,

I have an 2.0.9 openvpn server installed in a linux box but I need to access from a vista client.   I noticed that vista support was added in 2.1 series so I'd like to know if it is stable enough to be used with my current server or do I need to upgrade the server also.

regards.

I run OpenVPN 2.0.9 on Vista without problem.  However, I did need to add the following options to my client configuration under Vista for it to work properly:

route-method exe
tap-sleep 5

OpenVPN 2.0.9 can't use the IPAPI route method (which is the default for OpenVPN) due to some internal changes between XP and Vista, and the sleep appears to be necessary in some cases for the tap device to be ready for use.
-- 
Josh

Attachment: signature.asc
Description: OpenPGP digital signature