[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] I Cannot "See" Clients On The Network


  • Subject: Re: [Openvpn-users] I Cannot "See" Clients On The Network
  • From: Erich Titl <erich.titl@xxxxxxxx>
  • Date: Fri, 20 Jul 2007 11:36:53 +0000


Jake Conk wrote:
> Hello,
> 
> I am running FreeBSD 6.2 and installed the OpenVPN 2.0.6 port but for
> the life of me cannot get my machine to see any of the clients on the
> remote network.
> 
> The remote network's LAN's IP range was 192.168.10.0/24
> <http://192.168.10.0/24> and I have the server configuration set to add
> the route to my clients computers by this, push "route 192.168.10.0
> <http://192.168.10.0> 255.255.255.0 <http://255.255.255.0>", and the
> server directive is set to, server 192.168.50.0 <http://192.168.50.0>
> 255.255.255.0 <http://255.255.255.0>, so when I connect to I get
> assigned an IP address of 192.168.50.6 <http://192.168.50.6>. I also
> have the configuration "client-to-client" so that I could connect to
> other machines on that network.
> 
> I have 3 other servers on the remote network with the static IPs of
> 192.168.10.10 <http://192.168.10.10>, 192.168.10.20
> <http://192.168.10.20>, and 192.168.10.30 <http://192.168.10.30> but I
> cannot ping them when I connect to openvpn for some reason. The only
> machine I can ping on that network when I connect to the VPN is the
> server I connected to.
> 
> Everything else seems to work perfectly such as push "redirect-gateway"
> feature.
> 
> I'm using the normal routing setup so I dunno whats wrong why I cannot
> connect to any clients on the remote network.

Probably routing, look for the return route.

cheers

Erich

____________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users