[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] Openvpn and win2003 as a internet gateway?


  • Subject: Re: [Openvpn-users] Openvpn and win2003 as a internet gateway?
  • From: "Thor Selnes" <thor918@xxxxxxxxx>
  • Date: Sun, 8 Jul 2007 16:42:46 +0200
  • Importance: normal
  • Priority: normal

I got to note that

I did not use the ccd directive in the config. I only tested that because I was desperate when it didn’t work.

So far my new setup are working perfectly.

 

Fra: openvpn-users-bounces@xxxxxxxxxxxxxxxxxxxxx [mailto:openvpn-users-bounces@xxxxxxxxxxxxxxxxxxxxx] På vegne av Thor Selnes
Sendt: 8. juli 2007 13:23
Til: Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
Emne: Re: [Openvpn-users] Openvpn and win2003 as a internet gateway?

 

Okey. I have it working now.

I was running OpenVPN 2.0.9 -- released on 2006.10.01

And the only change I did was upgrading to OpenVPN 2.1_rc4 -- released on 2007.04.25

From that on everything started to work, so I’m guessing what I had problems with was a bug that is fixed?

Anyways, thanks for helping me ;)

 

Thor

 

Fra: openvpn-users-bounces@xxxxxxxxxxxxxxxxxxxxx [mailto:openvpn-users-bounces@xxxxxxxxxxxxxxxxxxxxx] På vegne av Thor Selnes
Sendt: 8. juli 2007 11:37
Til: Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
Emne: Re: [Openvpn-users] Openvpn and win2003 as a internet gateway?

 

By the way

Adding this to the server config

client-config-dir ccd

and this to the client text file in ccd dir

iroute 10.0.0.0 255.255.255.0

 

makes the errors in the log dissapear, but still no dice!

 

 

 

 

Fra: openvpn-users-bounces@xxxxxxxxxxxxxxxxxxxxx [mailto:openvpn-users-bounces@xxxxxxxxxxxxxxxxxxxxx] På vegne av Paul Wright
Sendt: 7. juli 2007 22:52
Til: Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
Emne: Re: [Openvpn-users] Openvpn and win2003 as a internet gateway?

 

The connection is made successfully… but traffic seems to be dropped on the win2003 server.

MULTI: bad source address from client [10.0.0.121], packet dropped

 

I'm guessing that a firewall rule is dropping the packet because it is sourced from an RFC1918 address.  What can you tell us about the configuration on the Win2003 server?

paul