[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

[Openvpn-users] Reconnect problem on windows


  • Subject: [Openvpn-users] Reconnect problem on windows
  • From: "Yongguo Yan" <ygyan2000@xxxxxxxxx>
  • Date: Tue, 26 Jun 2007 18:41:06 +0800

hi,

I am using 2.0.9 and noticed that the windows version has
 problem with reconnecting to the server when Inactivity timeout
happens.

In this case, the ip address before was 10.10.1.2. Then it got the push_reply:

Tue Jun 26 14:23:06 2007 us=800948 PUSH: Received control message:
'PUSH_REPLY,route-gateway 10.10.1.1,ping 15,ping-restart 120,ifconfig
10.10.1.3 255.255.255.0' <br>

It detected the change of ip address and tried to close and reopen
tun/tap device.

Tue Jun 26 14:23:06 2007 us=801076 NOTE: Pulled options changed on
restart, will need to close and reopen TUN/TAP device. <br>
Tue Jun 26 14:23:06 2007 us=804175 Closing TUN/TAP interface <br>
Tue Jun 26 14:23:07 2007 us=820751 TAP-WIN32 device [14] opened:
\\.\Global\{8769662D-CC3B-4836-B6A7-F924E9D1D490}.tap <br>
Tue Jun 26 14:23:07 2007 us=820802 TAP-Win32 Driver Version 8.4  <br>
Tue Jun 26 14:23:07 2007 us=820823 TAP-Win32 MTU=1500 <br>

It notified the tap-win32 driver.

Tue Jun 26 14:23:07 2007 us=820854 Notified TAP-Win32 driver to set a
DHCP IP/netmask of 10.10.1.3/255.255.255.0 on interface
{8769662D-CC3B-4836-B6A7-F924E9D1D490} [DHCP-serv: 10.10.1.0,
lease-time: 31536000] <br>

But unfortunately the ip address was not setup. The address was still 0.0.0.0.

Tue Jun 26 14:23:07 2007 us=825031 Successful ARP Flush on interface
[131079] {8769662D-CC3B-4836-B6A7-F924E9D1D490} <br>

Now it entered the long wait.
Tue Jun 26 14:23:07 2007 us=920172 TEST ROUTES: 0/0 succeeded len=1
ret=0 a=0 u/d=down <br>
Tue Jun 26 14:23:07 2007 us=920207 Route: Waiting for TUN/TAP
interface to come up... <br>
..................................................................................................................................

Tue Jun 26 14:23:37 2007 us=597873 TEST ROUTES: 0/0 succeeded len=1
ret=0 a=0 u/d=down <br>

Finally ended the sequence with error.

Tue Jun 26 14:23:37 2007 us=599860 Initialization Sequence Completed
With Errors

It seems the problem is related to the tun/tap-win device because
there is no problem with linux version.
______________________
OpenVPN mailing lists
https://lists.sourceforge.net/lists/listinfo/openvpn-users