[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Web openvpn.net

[Openvpn-users] remote client problem

  • Subject: [Openvpn-users] remote client problem
  • From: "Michael D. Berger" <m.d.berger@xxxxxxxx>
  • Date: Mon, 25 Jun 2007 17:43:05 -0400
  • Importance: Normal

I have an OpenVPN UDP bridge server running on
a Linux FC4 under a Vigor router.  For test
purposes, I have a Linksys router outside the
Vigor to serve as a test "WAN".  I run an
OpenVPN client on a laptop with WinXP on the
"WAN". It all works.  I can, for example, get
into directories on my Win2k boxes under the
Vigor. When I examine the TAP interface on the
laptop, I can see that IP address is as
specified on the server-bridge line.

Next I take my laptop to a hotspot either at
a coffee house or my church (with the Linksys
programmed to pass 1194 if it is still in the
system).  It doesn't work. here are some

1. The client log shows that it got the
   server-bridge information from the server,
   but it says it completed with errors.  It
   doesn't say what the errors are (at
   verbosity level 4).

2. The client TAP interface does not have a
   correct IP address.  Rather it has, for
   example,, which goog informs
   me is assigned by WinXP when it has nothing

3. IGMP packets appear on the

4. On the client, neither pings, nor any other
   attempt to access the internet, work. This
   problem persists after the OpenVPN
   client is closed, but can be corrected by
   logging off the hotspot and logging on again.

I note that with the "WAN" tests, the client is
wired, while at the hotspots, it is wireless.

I haven't yet tried it with TCP; I guess that
is next.  Any other suggestions?  I have
captured all related packets on the server if
there is something someone thinks I should look

Thanks for your help.


Michael D. Berger

Openvpn-users mailing list