[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Web openvpn.net

[Openvpn-users] Everything works except BitTorrent

  • Subject: [Openvpn-users] Everything works except BitTorrent
  • From: "U. N. Owen" <rivanor@xxxxxxxxxxx>
  • Date: Mon, 25 Jun 2007 16:43:30 +0000

Hi all,

I have tried for several days to resolve this problem on my own before asking for help.

Basically, I have got openvpn working beautifully (in routing mode) but BitTorrent is having issues. My BitTorrent client can connect to other peers (and receive connections from peers) but the connection will be closed (under mysterious circumstances) after only a few seconds. I've seen other posts about connections being dropped using some kind of "multi" mode (multicast maybe?) which does not seem to apply here. At least, I am not seeing any kind of messages in the log about connections being dropped.

Does anyone know where I could look to troubleshoot this problem? I am a developer and am comfortable compiling and setting breakpoints in a debugger so if someone could point me to the place in the code where connections get dropped, or where I could troubleshoot this, I would be very grateful.


PS - For what it's worth, I donated $50 a few days ago, so my appreciation for this awesome project does extend beyond words :)

Don?t miss your chance to WIN $10,000 and other great prizes from Microsoft Office Live http://clk.atdmt.com/MRT/go/aub0540003042mrt/direct/01/

OpenVPN mailing lists