[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Web openvpn.net

Re: [Openvpn-users] FC4 daemon with TAP

  • Subject: Re: [Openvpn-users] FC4 daemon with TAP
  • From: "Dave" <dev@xxxxxxxxxxxxxx>
  • Date: Thu, 21 Jun 2007 18:59:37 -0500
  • Importance: Normal

> I have found on Linux FC4, when I run a bridge
> openvpn as a daemon, certain other network
> operations are blocked.  For example, I cannot ping
> an outside location that I normally can ping.  The
> problem persists after the daemon and bridge are
> killed.  It is solved by with:
>     /etc/init.d/network restart
> which I therefore added to my shutdown script.
> There is no comparable problem if openvpn is run
> as a shell command rather than as a daemon.

Are you able to do anything with the network after runting the bridge start
script?  Personally, I was not able to on my machine (SuSE) and I had to
modify the script to add the default gateway back to the interface:

route add default gw

That line added at the bottom of the script (ip address obviously site

I have no idea if this will help you, but I certainly had to do it at least.


Openvpn-users mailing list