[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

[Openvpn-users] error running openvpn on arm / uclibc / softfloat


  • Subject: [Openvpn-users] error running openvpn on arm / uclibc / softfloat
  • From: Christopher Friedt <cfriedt@xxxxxxxxxxxxxxxxxx>
  • Date: Thu, 24 May 2007 11:08:55 +0200

Hi everyone,

At my company we're using openvpn on our most recent product line. We 
have several clients, although our devices are still in the research & 
development stage. In any event, most of the work we've done up until 
now depended heavily on the manufacturers of the boards that we use - 
technologic systems at www.embedddedarm.com. They've been quite 
traditional in sticking with a 2.4 kernel and a glibc userland for their 
embedded linux, which is heavily based around the debian / arm distribution.

I've been working hard for quite some time on getting the 2.6 kernel 
running on these boards, and several other developers have helped with 
this. I'm at the point now, where I've gotten most of the userspace up 
to par with what we need except for openvpn. For some reason, whenever I 
try to run openvpn, i receive this debugging message through gdb:

Assertion failed at integer.h:94

The VPN is running fine on all of the other boards that are using a 
glibc userland, and what I've done is simply built openvpn against 
uclibc and copied over my old certificates and keys.

Does anyone have any idea why this would happen? Has anyone else had 
experience running openvpn within a uclibc userspace on the arm?


Cheers,
______________________
OpenVPN mailing lists
https://lists.sourceforge.net/lists/listinfo/openvpn-users