[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] windows path problem


  • Subject: Re: [Openvpn-users] windows path problem
  • From: "Mike Haun" <mike.haun@xxxxxxxxxxxxx>
  • Date: Sun, 20 May 2007 18:05:57 -0400

On 5/20/07, Mathijs Kwik <bluescreen303@xxxxxxxxx> wrote:
Hello,

I successfully installed openVPN on a linux server in bridge mode.
linux and osX clients are connecting without a glitch.
Windows (as usual) is a totally different story...

i tried about 20 different ways to enter paths to my certificate files but it
keeps on giving me the same error.

my config-file has
ca "c:\\Program Files\\OpenVPN\\keys\\ca.crt"
cert "c:\\Program Files\\OpenVPN\\keys\\winclient1.crt"
key "c:\\Program Files\\OpenVPN\\keys\\winclient1.key"
in it

but i keep getting
Sun May 20 23:25:06 2007 OpenVPN 2.1_rc4 Win32-MinGW [SSL] [LZO2] built on Apr
25 2007
Sun May 20 23:25:06 2007 Cannot load certificate file C:\Program
Files\OpenVPN\keys\winclient1.crt: error:02001002:system library:fopen:No
such file or directory: error:20074002:BIO routines:FILE_CTRL:system lib:
error:140AD002:SSL routines:SSL_CTX_use_certificate_file:system lib
Sun May 20 23:25:06 2007 Exiting

any help?

greetings,
Mathijs


Is it Windows 'Vista'?  I had a very similar problem but never got back to it.  I think there is a beta version that will support Vista if I remember correctly.