[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

[Openvpn-users] Problems with redirect-gateway


  • Subject: [Openvpn-users] Problems with redirect-gateway
  • From: mylists@xxxxxxxxxxxxxxxxxxxx
  • Date: Wed, 16 May 2007 16:42:59 +0200 (CEST)
  • Importance: Normal

Hello all,

I have a routed vpn working with the following configuration:

   VPN server (linux box)                                   Laptop (winxp)
          |                                                     |
   nic0 xxx.xxx.xxx.xxx  ---> ADSL --- INET --- DIALUP -- xxx.xxx.xxx.xxx
          |                                                     |
   tun0 10.20.30.1 ---------------------------------------- 10.20.30.6
          |
   nic1 192.168.0.1
          |
          --------------> to local lan ...


>From the laptop I can ping both 10.20.30.1 and 192.168.0.1. I can also
ping any machine inside the 192.168.0.0 subnet. For that purpose I added
the following configuration server side:
push "route 192.168.0.0 255.255.255.0"

Now if I try to route all traffic to the vpn it breaks the full thing as
soon as I add the config line :
push "redirect-gateway def1"

After that, I restart my vpn connection, both parts connect with success,
but I am not able to ping 10.20.30.1. Nothing goes through.

In the firewall I am masquerading both 192.168.0.0 and 10.20.30.0 subnets
to the inet interface.

What am I missing please???

Thanks,
Josep

____________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users