[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] Linux to Windows problems


  • Subject: Re: [Openvpn-users] Linux to Windows problems
  • From: "Akuma Daimao" <akumadaimao@xxxxxxxxx>
  • Date: Thu, 3 May 2007 21:58:22 -0400

Ok...I read some more and learned that you apparently can't SSH tunnel
UDP connections. >_<  So I switched over to TCP and *poof* I can ping.

So, this problem has been solved.  Now to see about making everything
else work...

- Akuma

On 5/3/07, Akuma Daimao <akumadaimao@xxxxxxxxx> wrote:
> Hello,
>
> I've just started trying to use OpenVPN.  I've got the machine at home
> running Ubuntu 7.04 (feisty) and the laptop client is running XP SP2.
> Both machines are running OpenVPN 2.0.9.  I have a dynamic DNS service
> pointing to the server machine; I'll call it generic.dyndns.org.
>
> Because my school does application packet filtering, I have to run the
> connection through an SSH tunnel.  I'm using PuTTY for the tunnel;
> it's set to forward local port 5000 to remote port 1194 on
> generic.dyndns.org.
>
> I'm still trying to get this thing working, so I'm using the secret
> key setup.  Here's my config files:
>
> Server (Linux):
> dev tun
> ifconfig 10.8.0.1 10.8.0.2
> secret static.key
>
> Client (Windows):
> remote localhost
> port 5000
> dev tun
> ifconfig 10.8.0.2 10.8.0.1
> secret static_key.txt
>
> (static.key and static_key.txt are the same file; I renamed the file
> on the Windows machine so as not to accidentally execute it and mess
> with the registry.)
>
> Here's the output of the client log:
> Thu May 03 18:26:01 2007 OpenVPN 2.0.9 Win32-MinGW [SSL] [LZO] built
> on Oct  1 2006
> Thu May 03 18:26:01 2007 TAP-WIN32 device [VPN] opened:
> \\.\Global\{E0F2AF84-D412-40DF-953A-2F000A6A5DA8}.tap
> Thu May 03 18:26:01 2007 Notified TAP-Win32 driver to set a DHCP
> IP/netmask of 10.8.0.2/255.255.255.252 on interface
> {E0F2AF84-D412-40DF-953A-2F000A6A5DA8} [DHCP-serv: 10.8.0.1,
> lease-time: 31536000]
> Thu May 03 18:26:01 2007 Successful ARP Flush on interface [3]
> {E0F2AF84-D412-40DF-953A-2F000A6A5DA8}
> Thu May 03 18:26:01 2007 UDPv4 link local (bound): [undef]:9000
> Thu May 03 18:26:01 2007 UDPv4 link remote: 127.0.0.1:9000
> Thu May 03 18:26:12 2007 Peer Connection Initiated with 127.0.0.1:9000
> Thu May 03 18:26:12 2007 WARNING: 'ifconfig' is used inconsistently,
> local='ifconfig 10.8.0.2 10.8.0.1', remote='ifconfig 10.8.0.1
> 10.8.0.2'
> Thu May 03 18:26:13 2007 Initialization Sequence Completed
>
> relevant ipconfig output for client:
>
> Ethernet adapter VPN:
> Connection-specific DNS suffix:
> IP Address: 10.8.0.2
> Subnet Mask: 255.255.255.252
> Default Gateway:
>
> relevant ifconfig output for server:
> tun0      Link encap:UNSPEC  HWaddr
> 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
>           inet addr:10.8.0.1  P-t-P:10.8.0.2  Mask:255.255.255.255
>           UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
>           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:100
>           RX bytes:0 (0.0 b)  TX bytes:756 (756.0 b)
>
>______________________
OpenVPN mailing lists
https://lists.sourceforge.net/lists/listinfo/openvpn-users