[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

[Openvpn-users] Unstable connection


  • Subject: [Openvpn-users] Unstable connection
  • From: Bruno Sampayo <bruno@xxxxxxxxxxxxxx>
  • Date: Mon, 02 Apr 2007 17:00:39 -0300

Hey List,
    I have a Debian Firewall installed on my server which is running 
with a shorewall application, I'm install and configure OpenVPN 2.0 
i386-pc-linux like a master server, and everything is running fine on it.
    Log on firewall server (Openvpn Master) when a start openvpn:

    Mon Apr  2 16:36:11 2007 Socket Buffers: R=[111616->131072] 
S=[111616->131072]
    Mon Apr  2 16:36:11 2007 UDPv4 link local (bound): [undef]:5000
    Mon Apr  2 16:36:11 2007 UDPv4 link remote: [undef]
    Mon Apr  2 16:36:13 2007 Peer Connection Initiated with 
201.9.226.156:5000
    Mon Apr  2 16:36:14 2007 Initialization Sequence Completed
   
    I had install an openvpn on a branch office server(10.10.0.2) for 
make a VPN with my server (Debian Firewall 10.10.0.1), this branch 
office Server is behind of Router Server.
    When I start the openvpn application on the branch office at the 
first time, the log is:
       
       Mon Apr  2 13:48:50 2007 us=812408 Socket Buffers: 
R=[109568->131072] S=[109568->131072]                     Mon Apr  2 
13:46:42 2007 us=833409 UDPv4 link local (bound): [undef]:5000
       Mon Apr  2 13:46:42 2007 us=833682 UDPv4 link remote: 
201.6.103.194:5000
       Mon Apr  2 13:46:52 2007 us=521129 Peer Connection Initiated with 
201.6.103.194:5000
       Mon Apr  2 13:46:53 2007 us=737070 Initialization Sequence Completed
   
    Ok, Until here everything is running fine, but if a stop the 
client(openvpn on branch office) and try run again, sometimes the log 
stop in this case:
       Mon Apr  2 13:48:50 2007 us=812408 Socket Buffers: 
R=[109568->131072] S=[109568->131072]
       Mon Apr  2 13:48:50 2007 us=812745 UDPv4 link local (bound): 
[undef]:5000
       Mon Apr  2 13:48:50 2007 us=813024 UDPv4 link remote: 
201.6.103.194:5000
   
    And I don't have a Connection with the server by VPN, but sometimes 
if a stop and start again the connection's establish is fine.
    I don't know the solution for this case, I need establish the 
connection every time when I start the openvpn on branch office, how can 
I have it? I need configure something else?.
    Could someone help me with this problem?

Obs:
Operational system = Debian Sarge (Firewall/openvpn master)
Operational system = Debian etch (branch office/ openvpn client)


Thanks for help,
Bruno Sampayo
-- 
Bruno Sampayo <bruno@xxxxxxxxxxxxxx>
Tel.: +55(011) 50973005
Engenharia
Samurai Projetos Especiais
______________________
OpenVPN mailing lists
https://lists.sourceforge.net/lists/listinfo/openvpn-users