[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Web openvpn.net

[Openvpn-users] FW: Blocked Windows Authentication and a Plea for Help

  • Subject: [Openvpn-users] FW: Blocked Windows Authentication and a Plea for Help
  • From: "Stephen Gerstacker" <sgerstacker@xxxxxxxxxxxxxxxxxxxx>
  • Date: Mon, 18 Dec 2006 11:12:30 -0500

I've posted this a while back, but I still have no solution to my problem.
I begging that someone help me out.  The problem is driving me crazy.

The Problem:
When I VPN in, I ping everything on my network.  I can SSH into my UNIX
boxes.  I can connect to web servers running on my internal machines.  When
I attempt to connect to a Windows share, nothing happens for about 3
minutes.  I am then presented with a Windows authentication dialog.  I can't
type in my current credentials because Windows is awesome and won't let you
try them again.  Trying other credentials does nothing.

I also found that if I hit a site hosted on an IIS server that requires
authentication, the web browser tries for about 3 minutes and then gives a
'page cannot be displayed error'.

This leads me to believe that something is being lost with the
authentication protocol.

The Setup:
This originally started happening with an OpenVPN 2.0.6 server running on
OpenBSD 3.8.  The clients were using Windows XP SP2 with I believe the 2.0.6
GUI client.

I've since upgraded and tried many different configurations, including:

* OpenVPN 2.0.9 server on OpenBSD 3.8
* OpenVPN 2.0.9 server on OpenBSD 4.0
* OpenVPN 2.0.9 client
* OpenVPN 2.0.9 server on Ubuntu Edgy

The weirdest part is that with the original configuration worked for 6
months and then spontaneously stopped working.  My guess is that a Windows
patch killed it, but I'm surprised that no one else has experienced this.

I've attached my current configuration files.  This is for the 2.0.9 client
GUI, 2.0.9 server on Edgy behind an OpenBSD 4.0 firewall.  The log from the
client is also provided.

Our network's subnet is and our VPN subnet is

Again, please help.
Stephen Gerstacker

Attachment: server.conf
Description: Binary data

Attachment: client.ovpn
Description: Binary data

Attachment: client.log
Description: Binary data

Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
Openvpn-users mailing list