[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

[Openvpn-users] Problem (Bug?) with OpenVPN on multiple interfaces server


  • Subject: [Openvpn-users] Problem (Bug?) with OpenVPN on multiple interfaces server
  • From: Stefano Garavaglia <alter.ego@xxxxxx>
  • Date: Fri, 25 Nov 2005 12:22:34 +0100

I've had a problem (now solved) with OpenVPN 2.0.5, and I don't know if
it's a bug in OpenVPN handling of multiple interfaces or just a wrong
configuration.

I've installed OpenVPN server on a firewall with 4 NICs, 3 bound to 
ADSL and 1 on the internal net (eth0).

For the initial testing I used ADSL1 (eth1) and a computer connected
directly to the adsl router switch, and it worked well. At this time
in the server config there wasn't a "local a.b.c.d" line and the router
wasn't conencted to the interned due to a ISP problem. 

Being this test successful I moved the client computer to a remote
office, and the VPN couldn't start at all.  I tried also form a windows
computer as a client, but nothing worked.
This time I was trying to connect to my firewall trough ADSL2 (eth2).
After some thinkering about, I just added a line to server config:
local 217.60.x.x  (the ip of eth2 connected to ADSL2)
and now it works.

I think my solution is just a workaround, because now OpenVPN is
listening only on on ADSL2 and not on ADSL1 or ADSL3.

I've set different routes out of the firewall based also on the source
ip, and the default route out of the firewall is on ADSL2. Other servers
(apache and qmail) works correctly on all ADSLs, so I'm suspecting
OpenVPN is sending responses originating from the wrong ip, different
from the ip it receives packets from the client. 
Looking at logs on the server and on the client at the same time lookd
like server was receiving packets, but client couldn't get responses, so
I tried to add a "local a.b.c.d" line in server config to force OpenVPN
to work on just a single IP, and it worked correctly after that.

Can you tell me if it's a problem in OpenVPN or if there is some
configuration I'm missing? 

Ciao,
Stefano
-- 
Stefano Garavaglia <alter.ego@xxxxxx>


____________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users