[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] my-tap error [Disregard]


  • Subject: Re: [Openvpn-users] my-tap error [Disregard]
  • From: "Aaron P. Martinez" <ml@xxxxxxxxxxxxxx>
  • Date: Sun, 23 Jan 2005 19:50:46 -0600


On Sun, 2005-01-23 at 19:09, Aaron P. Martinez wrote:
> I have finally gotten my p-t-p connections between two linux machines up
> and running without a hitch. 
> 
> I'm moving on now to set up a multi-client server (on the same linux
> box) and windows roadwarrior client machines.  
> 
> I installed OpenVPN 2.0rc6 and when i did my new tap device shows up in
> the task bar with a red X through it and moving the cursor over it
> provides the error "my-tap:  a network cable is unplugged"  I looked at
> the properties and the advanced options.  There is NO mac address, am i
> supposed to set that myself?  The Media status is set to "application
> controlled" so I just chalked it up initially to not having the config
> files set up and openvpn not running.
> 
> I got my connfigs together (below) started openVPN on the Linux and it
> was listening on the new port just like it should.  I started it on the
> windows machine withthe following:
> openvpn --config warrior.ovpn
> 
> it looks like it is working, but the link never actually connects i
> suspect because the local link stays at 'undef' which as i read earlier
> means that the negotiation never finalizes and then goes to a restart
> after an inactivity timeout.  The log output is below.
> 
> Windows LOG
> Sun Jan 23 18:52:39 2005 us=211144 Current Parameter Settings:
> Sun Jan 23 18:52:39 2005 us=213952   config = 'vpn.ovpn'
> Sun Jan 23 18:52:39 2005 us=216728   mode = 0
> Sun Jan 23 18:52:39 2005 us=219514   show_ciphers = DISABLED
> Sun Jan 23 18:52:39 2005 us=222289   show_digests = DISABLED
> Sun Jan 23 18:52:39 2005 us=225062   show_engines = DISABLED
> Sun Jan 23 18:52:39 2005 us=227832   genkey = DISABLED
> Sun Jan 23 18:52:39 2005 us=230622   key_pass_file = '[UNDEF]'
> Sun Jan 23 18:52:39 2005 us=233401   show_tls_ciphers = DISABLED
> Sun Jan 23 18:52:39 2005 us=236574   proto = 0
> Sun Jan 23 18:52:39 2005 us=239811 NOTE: --mute triggered...
> Sun Jan 23 18:52:39 2005 us=242775 177 variation(s) on previous 10
> message(s) su
> ppressed by --mute
> Sun Jan 23 18:52:39 2005 us=249867 OpenVPN 2.0_rc6 Win32-MinGW [SSL]
> [LZO] built
>  on Dec 20 2004
> Sun Jan 23 18:52:39 2005 us=257839 IMPORTANT: OpenVPN's default port
> number is n
> ow 1194, based on an official port number assignment by IANA.  OpenVPN
> 2.0-beta1
> 6 and earlier used 5000 as the default port.
> Enter Private Key Password:
> Sun Jan 23 18:52:43 2005 us=199007 Control Channel Authentication: using
> 'c:/ope
> nvpn/keys/ta.txt' as a OpenVPN static key file
> Sun Jan 23 18:52:43 2005 us=210001 Outgoing Control Channel
> Authentication: Usin
> g 160 bit message hash 'SHA1' for HMAC authentication
> Sun Jan 23 18:52:43 2005 us=217100 Incoming Control Channel
> Authentication: Usin
> g 160 bit message hash 'SHA1' for HMAC authentication
> Sun Jan 23 18:52:43 2005 us=224739 LZO compression initialized
> Sun Jan 23 18:52:43 2005 us=228540 Control Channel MTU parms [ L:1542
> D:166 EF:6
> 6 EB:0 ET:0 EL:0 ]
> Sun Jan 23 18:52:43 2005 us=237608 Data Channel MTU parms [ L:1542
> D:1450 EF:42
> EB:23 ET:0 EL:0 AF:3/1 ]
> Sun Jan 23 18:52:43 2005 us=244758 Local Options String: 'V4,dev-type
> tun,link-m
> tu 1542,tun-mtu 1500,proto UDPv4,comp-lzo,keydir 1,cipher BF-CBC,auth
> SHA1,keysi
> ze 128,tls-auth,key-method 2,tls-client'
> Sun Jan 23 18:52:43 2005 us=255642 Expected Remote Options String:
> 'V4,dev-type
> tun,link-mtu 1542,tun-mtu 1500,proto UDPv4,comp-lzo,keydir 0,cipher
> BF-CBC,auth
> SHA1,keysize 128,tls-auth,key-method 2,tls-server'
> Sun Jan 23 18:52:43 2005 us=266295 Local Options hash (VER=V4):
> '504e774e'
> Sun Jan 23 18:52:43 2005 us=269910 Expected Remote Options hash
> (VER=V4): '14168
> 603'
> Sun Jan 23 18:52:43 2005 us=277086 Socket Buffers: R=[8192->8192]
> S=[8192->8192]
>  
> Sun Jan 23 18:52:43 2005 us=284137 UDPv4 link local: [undef]
> Sun Jan 23 18:52:43 2005 us=287957 UDPv4 link remote: 192.168.3.73:1195
> WSun Jan 23 18:52:43 2005 us=298798 read UDPv4: Invalid argument
> (WSAEINVAL) (co
> de=10022)
> RWWW
> 
> Linux Server LOG:
> Sun Jan 23 19:04:44 2005 us=93075 Current Parameter Settings:
> Sun Jan 23 19:04:44 2005 us=93364   config = 'roam.conf'
> Sun Jan 23 19:04:44 2005 us=93402   mode = 1
> Sun Jan 23 19:04:44 2005 us=93439   persist_config = DISABLED
> Sun Jan 23 19:04:44 2005 us=93476   persist_mode = 1
> Sun Jan 23 19:04:44 2005 us=93512   show_ciphers = DISABLED
> Sun Jan 23 19:04:44 2005 us=93548   show_digests = DISABLED
> Sun Jan 23 19:04:44 2005 us=93584   show_engines = DISABLED
> Sun Jan 23 19:04:44 2005 us=93620   genkey = DISABLED
> Sun Jan 23 19:04:44 2005 us=93656   key_pass_file = '[UNDEF]'
> Sun Jan 23 19:04:44 2005 us=93693   show_tls_ciphers = DISABLED
> Sun Jan 23 19:04:44 2005 us=93730   proto = 0
> Sun Jan 23 19:04:44 2005 us=93766   local = '[UNDEF]'
> Sun Jan 23 19:04:44 2005 us=93802   remote_list = NULL
> Sun Jan 23 19:04:44 2005 us=93843   remote_random = DISABLED
> Sun Jan 23 19:04:44 2005 us=93880   local_port = 1195
> Sun Jan 23 19:04:44 2005 us=93917   remote_port = 1195
> Sun Jan 23 19:04:44 2005 us=93953   remote_float = DISABLED
> Sun Jan 23 19:04:44 2005 us=93988   ipchange = '[UNDEF]'
> Sun Jan 23 19:04:44 2005 us=94024   bind_local = ENABLED
> Sun Jan 23 19:04:44 2005 us=94060 NOTE: --mute triggered...
> Sun Jan 23 19:04:44 2005 us=94132 156 variation(s) on previous 20
> message(s) suppressed by --mute
> Sun Jan 23 19:04:44 2005 us=94171 OpenVPN 2.0_rc6 i386-redhat-linux
> [SSL] [LZO] [EPOLL] built on Jan 23 2005
> Sun Jan 23 19:04:44 2005 us=258942 Diffie-Hellman initialized with 2048
> bit key
> Sun Jan 23 19:04:44 2005 us=260005 WARNING: file
> '/usr/share/openvpn/keys/cent.key' is group or others accessible
> Sun Jan 23 19:04:44 2005 us=262048 Control Channel Authentication: using
> '/usr/share/openvpn/keys/ta.key' as a OpenVPN static key file
> Sun Jan 23 19:04:44 2005 us=262147 Outgoing Control Channel
> Authentication: Using 160 bit message hash 'SHA1' for HMAC
> authentication
> Sun Jan 23 19:04:44 2005 us=262194 Incoming Control Channel
> Authentication: Using 160 bit message hash 'SHA1' for HMAC
> authentication
> Sun Jan 23 19:04:44 2005 us=262263 TLS-Auth MTU parms [ L:1542 D:166
> EF:66 EB:0 ET:0 EL:0 ]
> Sun Jan 23 19:04:44 2005 us=263033 TUN/TAP device tun0 opened
> Sun Jan 23 19:04:44 2005 us=263135 TUN/TAP TX queue length set to 100
> Sun Jan 23 19:04:44 2005 us=263222 /sbin/ifconfig tun0 10.8.0.1
> pointopoint 10.8.0.2 mtu 1500
> Sun Jan 23 19:04:44 2005 us=270490 /sbin/route add -net 10.8.0.0 netmask
> 255.255.255.0 gw 10.8.0.2
> Sun Jan 23 19:04:44 2005 us=277123 Data Channel MTU parms [ L:1542
> D:1450 EF:42 EB:23 ET:0 EL:0 AF:3/1 ]
> Sun Jan 23 19:04:44 2005 us=279411 GID set to openvpn
> Sun Jan 23 19:04:44 2005 us=279590 UID set to openvpn
> Sun Jan 23 19:04:44 2005 us=279672 Socket Buffers: R=[65535->131070]
> S=[65535->131070]
> Sun Jan 23 19:04:44 2005 us=279766 UDPv4 link local (bound):
> [undef]:1195
> Sun Jan 23 19:04:44 2005 us=279802 UDPv4 link remote: [undef]
> Sun Jan 23 19:04:44 2005 us=279845 MULTI: multi_init called, r=256 v=256
> Sun Jan 23 19:04:44 2005 us=279999 IFCONFIG POOL: base=10.8.0.4 size=62
> Sun Jan 23 19:04:44 2005 us=280099 IFCONFIG POOL LIST
> Sun Jan 23 19:04:44 2005 us=280211 Initialization Sequence Completed
> 
> ..........and it never goes further
> 
> 
> The config files:
> 
> Server  warrior.conf:
> port 1195
> proto udp
> dev tun
> ca /usr/share/openvpn/keys/ca.crt
> cert /usr/share/openvpn/keys/cent.crt
> key /usr/share/openvpn/keys/cent.key
> dh /usr/share/openvpn/keys/dh2048.pem
> keepalive 10 120
> persist-key
> persist-tun
> verb 5
> mute 20
> tls-server
> user openvpn
> server 10.8.0.0 255.255.255.0
> ifconfig-pool-persist ipp.txt
> push "dhcp-option WINS 10.8.0.1"
> max-clients 10
> group openvpn
> comp-lzo
> tls-auth /usr/share/openvpn/keys/ta.key 0
> log-append openvpn.log
> status vpnstatus.log
> 
> 
> Client warrior.ovpn:
> 
> client
> remote 192.168.3.73 1195
> ns-cert-type server
> ca c:/openvpn/keys/ca.crt
> cert c:/openvpn/keys/aaron.crt
> key c:/openvpn/keys/aaron.txt
> tls-auth c:/openvpn/keys/ta.txt 1
> proto udp
> dev tun
> ip-win32 dynamic
> pull
> ping-restart 60
> ping-timer-rem
> persist-tun
> persist-key
> resolv-retry 86400
> ping 10
> comp-lzo
> verb 5
> mute 10
> nobind  (i have tried w/and w/o this)
> 
> Any ideas?  My tap device never goes to a connected state
> 
> Any help appreciated.
> 
> Thanks,
> 
> Aaron Martinez
> 
Sorry everyone, i had more firewalls in place than i thought. 

Thanks,

Aaron


____________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users