[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] Configure driving me nuts


  • Subject: Re: [Openvpn-users] Configure driving me nuts
  • From: James Yonan <jim@xxxxxxxxx>
  • Date: Wed, 19 Jan 2005 02:29:31 -0700 (MST)


On Tue, 18 Jan 2005, Andrew Niemantsverdriet wrote:

> I am trying to compile openvpn-2.0 rc 6 on a redhat 9 box but it is not
> working. 
> 
> I am using this to compile:
> ./configure --with-ssl-headers=/usr/include/
> 
> That brings up this error:
> configure: checking for OpenSSL SSL Library and Header files...
> checking openssl/ssl.h usability... no
> checking openssl/ssl.h presence... no
> checking for openssl/ssl.h... no
> configure: error: OpenSSL SSL headers not found.
> 
> A locate of the file in question revels:
> 
> [root@localhost openvpn-2.0_rc6]# locate ssl.h
> /root/openvpn-2.0_rc6/ssl.h
> /usr/include/openssl/kssl.h
> /usr/include/openssl/ssl.h
> 
> What is the deal? I know it must be something simple but google has not
> returned anything useful. I have not ever had this problem before with
> other openvpn installs.
> 
> Any hints?

Try

  ./configure --with-ssl-headers=/usr/kerberos/include

If that doesn't work, try

  export CPPFLAGS=-I/usr/kerberos/include
  ./configure

James


-------------------------------------------------------
The SF.Net email is sponsored by: Beat the post-holiday blues
Get a FREE limited edition SourceForge.net t-shirt from ThinkGeek.
It's fun and FREE -- well, almost....http://www.thinkgeek.com/sfshirt
_______________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users