[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] Tunnel Traffic not passing during route-up script execution


  • Subject: Re: [Openvpn-users] Tunnel Traffic not passing during route-up script execution
  • From: Mark Wiater <mwiater@xxxxxxxxxxxxxx>
  • Date: Tue, 04 Jan 2005 16:16:54 -0500

On Tue, 2005-01-04 at 21:51 +0100, Mathias Sundman wrote:
> On Tue, 4 Jan 2005, Mark Wiater wrote:
> 
> > Hello,
> >
> > I've got a little problem with a site to site OpenVpn configuration. The
> > short of it is that I'm trying to measure bandwidth through the tunnel
> > so I can implement dynamic bandwidth shaping, but traffic generated to
> > measure the bandwidth never gets into the tunnel.
> 
> That's the way it is :-)
> 
> You have to call a second script from your route-up script and immediatly 
> return control to OpenVPN.
> 
> OpenVPN will not process any packets until the route-up script has 
> finished.
> 

Thanks Mathias. All better.

Now that you mention it, it occurs to me that I've heard this discussed
before but I can't find a reference to it for the life of me.

Thanks again.

-- 
Mark



-------------------------------------------------------
The SF.Net email is sponsored by: Beat the post-holiday blues
Get a FREE limited edition SourceForge.net t-shirt from ThinkGeek.
It's fun and FREE -- well, almost....http://www.thinkgeek.com/sfshirt
_______________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users