[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] Tunnel Traffic not passing during route-up script execution


  • Subject: Re: [Openvpn-users] Tunnel Traffic not passing during route-up script execution
  • From: Mathias Sundman <mathias@xxxxxxxxxx>
  • Date: Tue, 4 Jan 2005 21:51:37 +0100 (CET)

On Tue, 4 Jan 2005, Mark Wiater wrote:

Hello,

I've got a little problem with a site to site OpenVpn configuration. The
short of it is that I'm trying to measure bandwidth through the tunnel
so I can implement dynamic bandwidth shaping, but traffic generated to
measure the bandwidth never gets into the tunnel.

That's the way it is :-)

You have to call a second script from your route-up script and immediatly return control to OpenVPN.

OpenVPN will not process any packets until the route-up script has finished.

--
_____________________________________________________________
Mathias Sundman                  (^)   ASCII Ribbon Campaign
OpenVPN GUI for Windows           X    NO HTML/RTF in e-mail
http://www.nilings.se/openvpn    / \   NO Word docs in e-mail


------------------------------------------------------- The SF.Net email is sponsored by: Beat the post-holiday blues Get a FREE limited edition SourceForge.net t-shirt from ThinkGeek. It's fun and FREE -- well, almost....http://www.thinkgeek.com/sfshirt _______________________________________________ Openvpn-users mailing list Openvpn-users@xxxxxxxxxxxxxxxxxxxxx https://lists.sourceforge.net/lists/listinfo/openvpn-users