[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

[Openvpn-users] setting up bridging with linux server and WinXP client


  • Subject: [Openvpn-users] setting up bridging with linux server and WinXP client
  • From: Andy Howell <AndyHowell@xxxxxxxxxxxxx>
  • Date: Wed, 29 Dec 2004 13:13:14 -0600


I am trying to setup an ethernet bridge to connect my laptop via wifi to my linux box. I can establish a vpn link, but can not get the routing to work on windows. On the windows side I have openVPN version 2.0_rc1 and linux is 2.0_rc6.


There are a few wierd things in the client's log file that I don't unserstand:

The'route-gateway' shows up twice. The 172.16.1.3 is the correct one.
In the server log I see "push_list = 'route-gateway 172.16.3.0,ping 10,ping-restart 120'. I guess I'm not configuring this correctly.


Wed Dec 29 12:30:33 2004 us=419600 PUSH: Received control message: 'PUSH_REPLY,route-gateway 172.16.3.0,ping 10,ping-restart 120,route-gateway 172.16.1.3,ifconfig 172.16.3.2 255.255.0.0'

I assume this next one is not really an error, that it applies to routing vs. bridging:

Wed Dec 29 12:30:33 2004 us=419725 WARNING: --remote address [172.16.1.3] conflicts with --ifconfig subnet [172.16.3.2, 255.255.0.0] -- local and remote addresses cannot be inside of the --ifconfig subnet. (silence this warning with --ifconfig-nowarn)

Wed Dec 29 12:30:33 2004 us=422124 TAP-WIN32 device [TAP] opened: \\.\Global\{5655D8D4-EFEF-4D1B-A5B8-446D98390FFA}.tap
Wed Dec 29 12:30:33 2004 us=422158 TAP-Win32 Driver Version 8.1
Wed Dec 29 12:30:33 2004 us=422174 TAP-Win32 MTU=1500
Wed Dec 29 12:30:33 2004 us=422196 Notified TAP-Win32 driver to set a DHCP IP/netmask of 172.16.3.2/255.255.0.0 on interface {5655D8D4-EFEF-4D1B-A5B8-446D98390FFA} [DHCP-serv: 172.16.0.0, lease-time: 31536000]
Wed Dec 29 12:30:33 2004 us=514912 Successful ARP Flush on interface [6] {5655D8D4-EFEF-4D1B-A5B8-446D98390FFA}


After that comes up, it looks like windows has the TAP device setup, but I can't get anything across the interface. Once this is up, I can't see anything on the 172.16.255.255 net

Ethernet adapter TAP:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : TAP-Win32 Adapter V8
Physical Address. . . . . . . . . : 00-FF-56-55-D8-D4
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 172.16.3.2
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . : 172.16.0.0
Lease Obtained. . . . . . . . . . : Wednesday, December 29, 2004 12:45:36 PM
Lease Expires . . . . . . . . . . : Thursday, December 29, 2005 12:45:36 PM



My config files are as follows:

Server Config:

port 1194
proto udp
dev tap
ca keys/ca.crt
cert keys/mycert.crt
key keys/mycert.key
dh keys/dh2048.pem
ifconfig-pool-persist ipp.txt
server-bridge 172.16.3.0 255.255.0.0 172.16.3.50 172.16.3.100
client-config-dir ccd
keepalive 10 120
comp-lzo
persist-key
persist-tun
status openvpn-status.log
verb 5

Windows Client Config:

client
dev tap
proto udp
remote 172.16.1.3 1194
resolv-retry infinite
nobind
persist-key
persist-tun
ca keys/ca.crt
cert keys/enduring.crt
key keys/enduring.key
comp-lzo
verb 5

in the client's ccd file, I have:

ifconfig-push 172.16.3.2 255.255.0.0
push "route-gateway 172.16.1.3"

Thanks,

	Andy


____________________________________________ Openvpn-users mailing list Openvpn-users@xxxxxxxxxxxxxxxxxxxxx https://lists.sourceforge.net/lists/listinfo/openvpn-users