[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] Mac Tun/Tap drivers & the GUI installer, 10.3.7


  • Subject: Re: [Openvpn-users] Mac Tun/Tap drivers & the GUI installer, 10.3.7
  • From: Jon Bendtsen <jon.bendtsen@xxxxxxxxxx>
  • Date: Mon, 27 Dec 2004 10:01:23 +0100

Den 27. dec 2004, kl. 9:49, skrev Matthew Barr:

I've looked over the archives of the list on gmane, and haven't seen any current status on Mac installs.

I've tried building my own openvpn & using the version from the installer, downloaded an hour ago, from the gui folks.
It matches the message I was getting when I installed my own copies of the TAP/TUN drivers.


I'm getting a message:
Mon Dec 27 03:23:06 2004 us=732913 Cannot allocate TUN/TAP dev dynamically
Mon Dec 27 03:23:06 2004 us=735236 Exiting

Do you run it as root ?


It's occurring well after the initial contact w/ the server system, and after it has pushed various config settings down. I can see those in the log. It negotiates the cipher, etc. I'm guessing the issue isn't with openvpn, but want to see if anyone else is experiancing issues with this, or can offer troubleshooting advise. I'd like to help the TUN/TAP driver folks out to fix the issue, but don't know enough about their use to do so.

I'm trying to use a TUN interface, btw, but both of them are running, and show up as /dev/tap0 & /dev/tun0.

I also deleted the copies of the drivers (followed uninstall directions from Readme) and the binary (/usr/local/sbin/openvpn* ) and tried to reinstall via the Mac installer.

No luck.. same error.

I want to see if other people are using the Mac drivers sucessfully under 10.3.7, and if others have been able to install cleanly since the 10.3.7 update.

i use it, but i have only changed openvpn, not my tun driver.



JonB


____________________________________________ Openvpn-users mailing list Openvpn-users@xxxxxxxxxxxxxxxxxxxxx https://lists.sourceforge.net/lists/listinfo/openvpn-users