[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] VPN over Proxy Question


  • Subject: Re: [Openvpn-users] VPN over Proxy Question
  • From: "Cole" <cole@xxxxxxxxxxxx>
  • Date: Wed, 22 Dec 2004 19:23:03 +0200

Hey

Thanks for the reply, but i tried it without the http first, and I get 403 Forbidden. Thats why im asking, since i've tried both now
and i have no idea anymore.

If anyone has any further suggestions, it would be great, thanks

/Cole

----- Original Message -----
From: "Piergiorgio Spagnolatti" <draxx@xxxxxxxx>
Cc: <openvpn-users@xxxxxxxxxxxxxxxxxxxxx>
Sent: Wednesday, December 22, 2004 6:47 PM
Subject: Re: [Openvpn-users] VPN over Proxy Question


>
> Cole wrote:
>
> >Hey
> >
> >I have setup and been playing with openvpn and everything has been great, managed to get it all working fine, except for the vpn
> >over a proxy connection.
> >
> >Here are the command lines for both sides of the vpn, and in the logs, i get a 404 Not Found error.
> >
> >On the listening side.
> >Openvpn --proto tcp-server --dev tun0 --ifconfig 10.8.0.2 10.8.0.1 --verb 9 --daemon --log-append /var/log/openvpn.log
> >On the client side
> >Openvpn --proto tcp-client --dev tun2 --remote http://our.external.server --ifconfig 10.8.0.1 10.8.0.2 --verb 9 --http-proxy
> >ip.of.proxy 3128 up.txt --log-append /var/log/openvpn.log
> >
> >up.txt is just a file with the username/password for the proxy.
> >Now when i do this, i get a HTTP 404 Not Found error
> >The server side is listening on port 1194
> >The client side is tryign to connect with this line -
> >Wed Dec 22 18:22:41 2004 us=719362 Send to HTTP proxy: 'CONNECT http://our.external.server:1194 HTTP/1.0'
> >Wed Dec 22 18:22:41 2004 us=719411 Attempting Basic Proxy-Authorization
> >Wed Dec 22 18:22:41 2004 us=719424 Send to HTTP proxy: 'Proxy-Authorization: Basic [encrypted pass here]'
> >Wed Dec 22 18:22:43 2004 us=828731 HTTP proxy returned: 'HTTP/1.0 404 Not Found'
> >Wed Dec 22 18:22:43 2004 us=828816 HTTP proxy returned bad status
> >Wed Dec 22 18:22:43 2004 us=828840 TCP/UDP: Closing socket
> >
> >I wanted to know is there something i am doing wrong, or do need to not append the external server with http:// or does the
> >listenign side also need to connect back via the proxy?
> >
> >If anyone could suggest anything, it would be muchly appreciated.
> >
> >Thanks
> >/Cole
> >
> >
> >
> >
> >
> the "http://"; isn't surely needed since openvpn is not talking http!
> just use the ip/port of the server.
>
> The listening side as no special requirements apart from listening on
> the specified port. Since the proxy is the one that establishes the
> connection to the server, all traffic goes on that socket. No two-way
> connections, as one should expect! :-)
>
> Bye
>  Draxx
>
>
> -------------------------------------------------------
> SF email is sponsored by - The IT Product Guide
> Read honest & candid reviews on hundreds of IT Products from real users.
> Discover which products truly live up to the hype. Start reading now.
> http://productguide.itmanagersjournal.com/
> _______________________________________________
> Openvpn-users mailing list
> Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
> https://lists.sourceforge.net/lists/listinfo/openvpn-users


____________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users