[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] WAIT status via Management Interface


  • Subject: Re: [Openvpn-users] WAIT status via Management Interface
  • From: James Yonan <jim@xxxxxxxxx>
  • Date: Sun, 19 Dec 2004 16:57:38 -0700 (MST)

On Sun, 19 Dec 2004, Steven Palm wrote:

> 
> Curious question...
> 
> I see the WAIT message in the Management Interface documented as such:
> 
> WAIT          -- (Client only) Waiting for initial response from server.
> 
> However, I bring a tunnel up and get the CONNECTED state, and then 
> after a while it received WAIT over the management interface, and that 
> is the last status update I received.
> 
> Why do I get a message about waiting for an initial response after the 
> tunnel is already connected?  I thought that maybe my GUI had lost it's 
> socket connection to the management interface, but I cannot get in from 
> another process so I assume the connection is still active. Even if 
> this was a result of a re-connect attempt, wouldn't it leave me with 
> another CONNECTED message when it finished?

That WAIT is probably happening because of a TLS renegotiation (it happens 
once per hour by default).  Because the renegotiation takes a somewhat 
different path through the code, it's not finishing with a CONNECTED.  
I'm thinking that TLS renegotiations should probably not transition the 
state, so expect these mid-session WAITs to disappear in the future.

James


____________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users