[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] Openvpn doesn't work on VPS (Virtuozzo)


  • Subject: Re: [Openvpn-users] Openvpn doesn't work on VPS (Virtuozzo)
  • From: Terry Inzauro <tinzauro@xxxxxxxxxxxxxxxx>
  • Date: Sun, 19 Dec 2004 14:13:42 -0600

Victor Soroka wrote:
Hello! I has wrote this question to sourceforge openvpn forum 3 days ago
but got no answers. Maybe I'll find help in this list.

I have VPS based on plesk/virtuozzo and trying to to run openvpn inside
VPS. These errors I got from syslog: Dec 16 06:00:28 ve207 openvpn[24100]: OpenVPN 2.0_rc1 i386-redhat-linux-
gnu [SSL] [LZO] [EPOLL] built on Dec 12 2004 Dec 16 06:00:28 ve207 openvpn[24100]: Diffie-Hellman initialized with
1024 bit key Dec 16 06:00:28 ve207 openvpn[24100]: TLS-Auth MTU parms [ L:1558 D:138
EF:38 EB:0 ET:0 EL:0 ] Dec 16 06:00:28 ve207 openvpn[24100]: Note: Cannot open TUN/TAP
dev /dev/net/tun: Permission denied (errno=13) Dec 16 06:00:28 ve207 openvpn[24100]: Note: Attempting fallback to
kernel 2.2 TUN/TAP interface Dec 16 06:00:28 ve207 openvpn[24100]: Cannot allocate TUN/TAP dev
dynamically Dec 16 06:00:28 ve207 openvpn[24100]: Exiting [root@ve207 root]# ll /dev/net/tun crw-rw-rw- 1 root root 10, 200 Dec 12 10:59 /dev/net/tun Guys from hosting company wrote:


I checked with our vps tech and he said you should have access enough to do this, since you have root access to your vps server. You will need to check with the openvpn community to see how you get this to work on Redhat9/Virtuozzo, and Plesk

Victor.




-------------------------------------------------------
SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now. http://productguide.itmanagersjournal.com/
_______________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users

Hmmm. it may not be a permissions issue. try setting the tun device statically. eg. force it to use tun0 or tun1 int the config file. (dev tun1)




_Terry





____________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users