[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

[Openvpn-users] Securing *all* traffic over a wireless network - how?


  • Subject: [Openvpn-users] Securing *all* traffic over a wireless network - how?
  • From: Louis <openvpn@xxxxxxxxxxxxxxxxxxx>
  • Date: Sun, 12 Dec 2004 18:25:49 -0500


OpenVPN,

I would like to use OpenVPN over my public wireless access point, and have *all* traffic encrypted. Right now it appears that some traffic (DNS/..) is routed in clear text.

I see that in 2.0 b2 [http://openvpn.sourceforge.net/changelog.html] a local flag was added:
"Added 'local' flag to --redirect-gateway for use on networks where both OpenVPN daemons are connected to a shared subnet, such as wireless." which I believe is what I am looking for. But using the client in Linux, I get a config error on this. I wasn't able to find any history of this issue in the mailing list or searching online.


OpenVPN 2.0_rc1 i386-redhat-linux-gnu [SSL] [LZO] [EPOLL] built on Dec 11 2004
...
Dec 12 17:47:15 mybox openvpn[5597]: PUSH: Received control message: 'PUSH_REPLY,redirect-gateway 'local',route-gateway 10.1.1.1,ifconfig 10.1.1.2 255.255.255.224'
Dec 12 17:47:15 mybox openvpn[5597]: Options error: unknown --redirect-gateway flag: 'local'
Dec 12 17:47:15 mybox openvpn[5597]: OPTIONS IMPORT: --ifconfig/up options modified
Dec 12 17:47:15 mybox openvpn[5597]: OPTIONS IMPORT: route options modified
Dec 12 17:47:15 mybox openvpn[5597]: TUN/TAP device tap0 opened
Dec 12 17:47:15 mybox openvpn[5597]: TUN/TAP TX queue length set to 100


# uname -a
Linux mybox 2.6.9-1.667 #1 Tue Nov 2 14:41:25 EST 2004 i686 i686 i386 GNU/Linux


# rpm -qa | grep openvpn
openvpn-2.0_rc1-1

cat /etc/openvpn/client.conf
remote 192.168.3.1
port 5000
;dev tun
dev tap
ping 10
;comp-lzo
verb 4
mute 10
tls-client
ca my-ca.crt
cert client.crt
key client.key
pull
verb 4

Client is running Linux, Fedora Core 3:
OpenVPN 2.0_rc1 i386-redhat-linux-gnu [SSL] [LZO] [EPOLL] built on Dec 11 2004


Server is running M0n0wall 1.2b3
OpenVPN 2.0_beta11 i386-unknown-freebsd4.10 [SSL] built on Oct 23 2004

If anyone can tell me how to get the local flag working, or what I need to do to get all traffic going over the TAP/TUN links please let me know, thanks,

Louis





____________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users