[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] rpmbuild dependency problems with rc1


  • Subject: Re: [Openvpn-users] rpmbuild dependency problems with rc1
  • From: "Doncho N. Gunchev" <mr700@xxxxxxxxxxxx>
  • Date: Fri, 10 Dec 2004 01:42:20 +0200

On 2004-12-10 (Friday) 01:17, Doncho N. Gunchev wrote:
> On 2004-12-09 (Thursday) 12:39, James Yonan wrote:
> > This was posted on the OpenVPN sourceforge bugs page:
> > 
> > **********
> > 
> > I got openvpn 2.0 rc1 and on my Fedora Core 3 system I
> > did a rpmbuild -tb openvpn-2.0_rc1.tar.gz
> > 
> > This all went very smoothly.
> > When I tried to install this package I got a failed
> > dependency over perl(Authen::PAM)
...
> > Does anyone know how to turn off this nonsense of rpmbuild triggering
> > mandatory dependencies based on stuff it finds in the sample-scripts directory?
> > 
>     AFAIK there are two ways. The first is easy - turn off authomatic
> package dependencies (what I use, because I was lazy to really fix it):
> --- cut ---
> AutoReq: 0
> Requires: openssl >= 0.9.7a-40 # well, the version is FC3 specific
> Requires: lzo >= 1.08
> # /bin/bash, /bin/sh, libc.so.6 and so on are always required...
> # check with rpm -qp --requires package
> --- cut ---
>     The second way was to 'filter' this dependancy. I'll try to find
> how this worked and post it...
> 
    The second way are infact two ways. The older solution is:
1. Make a shell script like (name filter-requires-openvpn.sh)
   /usr/lib/rpm/perl.req $* | grep -v 'perl(Authen::PAM)'
2. Add it as source (SOURCE2: filter-requires-openvpn.sh)
3. '%define __perl_requires %{SOURCE2}' in the spec file.
This should work in all cases.
    The script /usr/lib/rpm/perl.req is responsible for these
requirements. Looking at it I found it supports arguments, so
%define __perl_requires /usr/lib/rpm/perl.req --ignore_deps 'perl(Authen::PAM)'
did the trick for me. At this point I got a package that requires
perl, but openvpn can work without it...
    Hope this helps.

-- 
Regards,
  Doncho N. Gunchev    Registered Linux User #291323 at counter.li.org
  GPG-Key-ID: 1024D/DA454F79                        http://pgp.mit.edu
  Key fingerprint = 684F 688B C508 C609 0371  5E0F A089 CB15 DA45 4F79