[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

[Openvpn-users] Routing issue


  • Subject: [Openvpn-users] Routing issue
  • From: "Sam Dunham" <samdunham@xxxxxxx>
  • Date: Wed, 01 Dec 2004 10:16:23 -0500

I've got OpenVPN 2 (latest beta) installed on a Fedora Core 3 box
(server) and a Windows XP box (client). Took me a while to get the SSL
stuff worked out, but I got it working. I can connect to the server and
ping the VPN address (10.8.0.1) and ftp to that address, etc... What I
can't do is ping the internal address of the server (192.168.0.2). Until
I can do that, I can't connect to Samba on the server. I've tried
manipulating the routes on the server and the client to no avail. Before
starting OpenVPN on the server, route returns no mention of the 10.8.0.0
subnet, which is correct. Upon starting OpenVPN, I get the following
relevent info returned from route:

Destination        Gateway       Genmask           Flags    Metric   
Ref   Use   Iface
10.8.0.2           *             255.255.255.255   UH       0         0 
   0     tun0
10.8.0.0           pu.lic.ho.st  255.255.255.0     UG       0         0 
   0     eth0

Now, if I'm not crazy or a complete idiot, what I need is for 10.8.0.0
to be on tun0 and I don't need 10.8.0.2 to be routed at all on the
server side. At the very least, something ain't right. Assuming the
following, what route commands do I need to run on the server and client
sides?

Server internal network: 192.168.0.0
Server internal address: 192.168.0.2
Server external address: pub.lic.ho.st
Server VPN network:      10.8.0.0
Server VPN address:      10.8.0.1

Client VPN address:      10.8.0.2

Running routed, not bridged, btw.

Thanks in advance,
Sam
-- 
  Sam Dunham
  samdunham@xxxxxxx


____________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users