[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Web openvpn.net

Re: [Openvpn-users] tapinstall.exe failed on clean XP Home. (Fixed)

  • Subject: Re: [Openvpn-users] tapinstall.exe failed on clean XP Home. (Fixed)
  • From: Terry Dooher <tdooher.lists@xxxxxxxxxxxxxxxxx>
  • Date: Mon, 20 Sep 2004 13:50:53 +0100

James Yonan wrote:

On Fri, 17 Sep 2004, Terry Dooher wrote:

I've just installed 2.0beta11 on an XP home laptop with SP2 and full admin privs. No prior versions have been installed. The tapinstall stage warns me about the lack of signature, I click "Continue anyway" and the install fails.
I haven't personally seen this problem, though it has been reported by one or two others. See below the sample install log from my own XP SP2 machine which was successful. Your log isn't very explicit about which file it is that cannot be found.

This is what was driving me nuts. There's no way to get Windows to tell you what's missing. Filemon doesn't seem to show any supiciously failed file accesses, either. (Though there's a lot of cruft to wade through.)

However, remembering that "Cannot find the file specified" can just as
easily refer to a failed registry access as it can a failed file write,
I refined my googling and dug this interesting tidbit up:


If the RunOnce key is missing, then many types of driver installation
can fail. I tried re-creating the missing key on the problem system and
re-ran tapinstall. It worked!

This is possibly the single most useful bit of windows hackery I've read
in a long time :)

One for the troubleshooting page?


Openvpn-users mailing list