[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Web openvpn.net

Re: [Openvpn-users] Note: Cannot open TUN/TAP dev /dev/net/tun: Permission denied (errno=13)

  • Subject: Re: [Openvpn-users] Note: Cannot open TUN/TAP dev /dev/net/tun: Permission denied (errno=13)
  • From: Jon Bendtsen <jon.bendtsen@xxxxxxxxxx>
  • Date: Thu, 5 Aug 2004 11:14:15 +0200

Den 5. aug 2004, kl. 11:07, skrev Tarjei Huse:

On Thu, 2004-08-05 at 08:12, Jon Bendtsen wrote:
Den 4. aug 2004, kl. 19:24, skrev tarjei@xxxxx:


Commenting out the user and group params solved this issue. I'm not
sure was
wrong. I tried to create a simple openvpn user and group and run
openvpn as
that uid/gid, but that didn't help.

well, what are the permissions of /dev /dev/net /dev/net/tun
/dev/net/tun is root.root 0600 on both machines, running same os, same
openvpn, same kernel.

Same goes for /dev/net.

I tried to su to the opevnpnuser and cd into /dev/net, no problem.

So, it seems the only difference is that on one of the machines I run in
mode server, and the other I run p2p-mode.

If you have any suggestions you want tested, feel free to holler out.

mine are crw-r--r-- 1 root root 10, 200 May 27 12:30 tun and i run it as user nobody and group nogroup


____________________________________________ Openvpn-users mailing list Openvpn-users@xxxxxxxxxxxxxxxxxxxxx https://lists.sourceforge.net/lists/listinfo/openvpn-users