[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] Safe to use old clients (1.5) with new 2.0beta7 server mode?


  • Subject: Re: [Openvpn-users] Safe to use old clients (1.5) with new 2.0beta7 server mode?
  • From: "James Yonan" <jim@xxxxxxxxx>
  • Date: Tue, 27 Jul 2004 01:53:56 -0000

On Friday 23 July 2004 13:45, Evan Harris wrote:
> I've been waiting for the server mode a long time so that one port allowed
> through firewalls can support many client connections.  I'm using udp and
> tun.
>
> I'm thinking of testing the new stuff with our systems, but I'd like to
> know if it is safe/possible to use the new code in server mode on our vpn
> server with old 1.5 clients which is what all of our other systems use. 
> Many of those clients will be very hard to upgrade, so I'd like to do it
> over an extended time period.

The problem with connecting a 1.5 client to a 2.0 server is that the "pull" 
directive was only introduced in 2.0 and doesn't exist on 1.5.

And without being able to use "pull" on the clients, the utility of the 2.0 
server mode is vastly diminished.

James



____________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users