[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Web openvpn.net

[Openvpn-users] v1.6.0 compile oddness on a redhat 9 box.

  • Subject: [Openvpn-users] v1.6.0 compile oddness on a redhat 9 box.
  • From: "Khan St. Preest" <ksp@xxxxxxxxxxxx>
  • Date: Sun, 25 Jul 2004 07:43:37 -0500 (CDT)
  • Importance: Normal

I've compiled and installed openvpn on numerous systems ranging from
Redhat 6.1 to SuSE 9.1. All of them have compiled, installed, and worked

I've got this one Redhat 9 box, however, that won't complete the
./configure process, insisting that my ssl headers aren't available. The
last few lines of the configure output look like this.

configure: checking for OpenSSL SSL Library and Header files...
checking openssl/ssl.h usability... no
checking openssl/ssl.h presence... no
checking for openssl/ssl.h... no
configure: error: OpenSSL SSL headers not found.

However, I DO have the openssl-devel libraries installed.
"rpm -qa|grep openssl" yields this output.


Next, I look in openvpn's config.log for more details and see the
following entry that looks like it could be the problem to my
non-programmer eye.

/usr/include/openssl/kssl.h:72:18: krb5.h: No such file or directory

I check and I do also have that file installed but it's in
/usr/kerberos/include/krb5.h. I don't see a seperate configuration option
to tell openvpn where kerberos files are. I copied krb5.h to the openssl
folder where I presume ./configure is trying to find it but still no dice.

Before I get too much further into this can someone tell me if there's
just something odd about compiling openvpn 1.6.0 on Redhat 9 or if they've
seen this already and know what I should do?

Thank you.

Openvpn-users mailing list