[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] Route Errors using push


  • Subject: Re: [Openvpn-users] Route Errors using push
  • From: James Yonan <jim@xxxxxxxxx>
  • Date: Tue, 20 Jul 2004 01:32:15 -0500

On Tuesday 20 July 2004 00:01, Don Weeks wrote:
> One of my users sees this when my push occurs:
>
> Sun Jul 18 13:19:02 2004 ERROR: Windows route add command failed: system()
> returned error code 1
> Sun Jul 18 13:19:02 2004 Attempting to lock Win32 semaphore
> 'openvpn_netcmd' prior to net shell command (timeout = 600 sec)
> Sun Jul 18 13:19:02 2004 route ADD 192.168.20.0 MASK 255.255.255.0
> 192.168.2.1 'route' is not recognized as an internal or external command,
> operable program or batch file.
> Sun Jul 18 13:19:02 2004 ERROR: Windows route add command failed: system()
> returned error code 1

I've seen something like this before.  It happens when the PATH environmental 
variable doesn't include the \windows\system32 directory where route.exe is 
supposed to live.  You can test this by opening up a command prompt window on 
the problem machine and checking the PATH setting.

I'm thinking about changing the Windows version to set routes using the IP 
Helper API rather than by calling route.exe to work around this nonsense.

James

____________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users