[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

[Openvpn-users] Odd behavior installing 2.0-beta7 on WinXP


  • Subject: [Openvpn-users] Odd behavior installing 2.0-beta7 on WinXP
  • From: Mathias Sundman <mathias@xxxxxxxxxx>
  • Date: Thu, 1 Jul 2004 18:23:44 +0200 (CEST)

I got an odd behavior while I installed OpenVPN 2.0-beta7 on a co-workers laptop with WinXP today.

The installation went through just as it should, and it did not tell me to reboot.

However, when I launched openvpn it could successfully open the tap device, so windows showed network status connected, but when it tried to assign the IP address, openvpn failed with a message about the device not existing any longer. Unfortunally I don't have the exact message left.

Checking in "My Network places" showed the tap interface as "Local Area Connection 2", and seemed to work.

But running ipconfig /all did not show the tap interface.

So, then we rebooted the PC.

After booting, windows came up with the standard "Found New Hardware" dialog and the TAP interface was installed. But this time "Local Area Connection 3" was created! So I ended up with 2, now working, tap interfaces! As my ovpn config-file didn't have any "dev-node" option, it failed starting now too, but after removing the second tap interface everything worked as it should...


-- _____________________________________________________________ Mathias Sundman (^) ASCII Ribbon Campaign NILINGS AB X NO HTML/RTF in e-mail Tel: +46-(0)8-666 32 28 / \ NO Word docs in e-mail

____________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users