[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Web openvpn.net

Re: [Openvpn-users] no chance trying openvpn

  • Subject: Re: [Openvpn-users] no chance trying openvpn
  • From: pi <list@xxxxxxxxxxxx>
  • Date: Tue, 16 Mar 2004 22:41:11 +0100

Okay, Okay,

First I apologize if my previous mail was misunderstood.
This mail was not a shout it was an humoristic one
examples: I can really say "I'm not lucky with VPN solutions!!", I discovered today openvpn (tada.....)

If I decided to write this mail it's because I began to try to install the configuration described in a previous mail using XXswan 1 month ago (10 hours a day)!!!
I asked peoples if XXXswan had the possibility to do this. They said to me 'of course!!'
first I made the solution working in my lab but when I wanted to configure it over the Internet, nothing was working
then I posted on the users list --> I had some answers (most of them were bad)
I even worked actively with a guy 'RPM builder' to test in my lab his modules and helped many of the users posting on this list.
last week, it appeared to be a compiling problem with the RedHat9.0. I then posted on the dev list

The conclusion I had today is:

AFAIK, it's to allow roadwarriors behind a NAT gateway to connect to a IPSec server, and the networks behind it. You use the Xsubnet= to specify what internal IP address the NAT'd box is using, and I'm fairly certain there's not a way to also have a subnet behind it, without doing something exotic like gre tunnels over the ipsec link.

At this point, my head exploded   ;-)

I then looked for another product and found openvpn.
I began to try to install it and at this point I thought the story was starting again.
That's why I did some tests : (./configure, rpmbuild, download rpm from dag's repository, and so on...)

my VPN experience showed me that if I wanted to have informations and the possibility to help the community, I had to ask many questions at the same time to 'maybe' have an answer.
I'm working with linux solutions since 1996 and wan't to share my knowledge not just take your ideas.
The concept of saying "it's Linux you've got to find the solution by yourself" is not a good one to me.
That's why when I ask something it's because you probably already have had the same problems and can make me win some time (I'll do the same for you if I can).

Once more, I apologize
(I also apologize for my "french" english   ;-) )


AthlonRob wrote:

On Tue, 2004-03-16 at 11:35, pi wrote:

I can really say "I'm not lucky with VPN solutions!!"

I don't think luck has anything to do with it. I think if you take the time to really research these problems, you'll find solutions.

first: impossible to install it on my redhat9.0

I would hardly say impossible...

checking openssl/ssl.h usability... no
checking openssl/ssl.h presence... no
checking for openssl/ssl.h... no
configure: error: OpenSSL SSL headers not found.

# rpm -qa|grep ssl

You might need to pass, to configure, where the ssl libs are located.

I post a message on this list but no answer :-((

You didn't wait very long.

I tried to attach my config.log to this mail, but there's a limit of 40k/message.

That's what websites are for... if you have webspace somewhere, you can put your config.log up there, and tell us it is there. That uses FAR less bandwidth than posting it in the list itself. It also doesn't force those of us who don't want to see the log to download it. It leaves us with a choice... usually a good thing.

Mar 16 20:30:05 moulinsart modprobe: modprobe: Can't locate module char-major-10-200
Mar 16 20:30:05 moulinsart openvpn[2593]: Note: Cannot open TUN/TAP dev /dev/net/tun: No such device (errno=19)
Mar 16 20:30:05 moulinsart openvpn[2593]: Note: Attempting fallback to kernel 2.2 TUN/TAP interface
Mar 16 20:30:05 moulinsart openvpn[2593]: Cannot allocate TUN/TAP dev dynamically

Is the tun module loaded into your kernel? If it isn't, you have may wish to review the fundamentals of reading... TFM, specifically.


By all means, type in all caps and scream at a mailing list.

Hope this helps...


____________________________________________ Openvpn-users mailing list Openvpn-users@xxxxxxxxxxxxxxxxxxxxx https://lists.sourceforge.net/lists/listinfo/openvpn-users