[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Web openvpn.net

[Openvpn-users] VPN connection issues

  • Subject: [Openvpn-users] VPN connection issues
  • From: "Cedric Spence" <cspence@xxxxxxxxxxxxxx>
  • Date: Wed, 14 Jan 2004 16:44:19 -0800

I received the following error

"socket bind failed on local address 64.x.x.x:5045
the requested address is not valid in its context"

I decided to configure the tap-win32 adapter with the information that 
my ISP 
provided to be

IP Address

Primary DNS
Secondary DNS

It worked and the above error did not show up when I 
started openVPN config file

I get the following mesage

"link UDPv4 link remote: [undef]"

This happens on the windows 2000 server that has vpn installed and 
running as the
VPN server

when I run vpn from the client and try to connect I get the following 

"read udpv4: connection reset by peer <WSAECONNRESET> (code=10054)"

I am unable to establish a vpn connection here is the network setup

Windows 2000 server(open VPn installed and running as server-static ip 
address)--->firewall(port 5045 opened)-->internet<---windows 2000
(dynamic address)

This is the config file for the server

local 64.x.x.x
lport 5045
rport 5045
secret C:\rn.key
ping 10
dev tap

This is the config file for the client

remote 64.x.x.x
port 5045
secret D:\rn.key
dev tap

can some help me with this problem


Openvpn-users mailing list