[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] Problem with script


  • Subject: Re: [Openvpn-users] Problem with script
  • From: "James Yonan" <jim@xxxxxxxxx>
  • Date: Thu, 8 May 2003 05:50:29 -0000

Wayne,

There are probably errors occuring in your script ./soest.up, but the actual
error messages are not being shown.  Because of the way that the daemon
environment works, if scripts called by openvpn write to standard output or
standard error, those messages will NOT make it into the syslog.

A better way to test the script is to run openvpn in non-daemon mode.  If you
run openvpn at a command prompt, you will see errors in the script, if any exist.

You can also use shell redirection to a file in the script to capture errors
which occur when openvpn calls the script while in daemon mode.

James

Wayne Wilson <wayne@xxxxxxxxxxxx> said:

> I seem to be having a problem .. (probably me being stupid) I have
> installed OpenVPN in the past on my firewall at home and trying it again
> now .. but keep on getting this error
>  
> ------------- SNIP -----------------
> May  2 11:52:02 fw openvpn[4077]: tls_session_init: new session object,
> sid=ac1e4505 721890de
> May  2 11:52:02 fw openvpn[4077]: tls_session_init: entry
> May  2 11:52:02 fw openvpn[4077]: tls_session_init: new session object,
> sid=2ea9544b a0e5ca02
> May  2 11:52:02 fw openvpn[4077]: Control Channel MTU parms: mtu=1262
> extra_frame=38 extra_buffer=38 extra_tun=0
> May  2 11:52:02 fw openvpn[4077]: tun/tap device tun0 opened
> May  2 11:52:02 fw openvpn[4077]: /sbin/ifconfig tun0 192.168.3.9
> pointopoint 192.168.4.1 mtu 1258
> May  2 11:52:02 fw openvpn[4077]: ./soest.up tun0 1258 1300 192.168.3.9
> 192.168.4.1
> May  2 11:52:02 fw openvpn[4077]: script failed: shell command exited
> with error status: 126
> May  2 11:52:02 fw openvpn[4077]: Exiting
>  
> -------------- SNIP ----------------
>  
> If anybody has any ideas .. will be much appreciated .. my script for up
> command is 
>  
> route add -net 192.168.4.0 netmask 255.255.255.0 gw $5
>  
> I get the same error on the other side ... Running kernel 2.4.20 and
> OpenVPN openvpn-1.3.1-1mdk.i586.rpm
>  
> Thanks
> Wayne
>  
>  
>  
> 



-- 





-------------------------------------------------------
Enterprise Linux Forum Conference & Expo, June 4-6, 2003, Santa Clara
The only event dedicated to issues related to Linux enterprise solutions
www.enterpriselinuxforum.com

_______________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users