[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] MULTI: bad source address from client [217.164.246.54], packet dropped


  • Subject: Re: [Openvpn-users] MULTI: bad source address from client [217.164.246.54], packet dropped
  • From: Erich Titl <erich.titl@xxxxxxxx>
  • Date: Wed, 18 Jul 2007 14:28:54 +0000

Hi Pete

Peter Njiiri wrote:
> 
> 
> Hi Erich
> 
> Below are the logs, please note that this client (Linux) is in the
> office (10.0.0.59) while the 217.164.246.54 is my client (Windows XP
> SP2) at home. It happens right after connecting and sometimes after
> pinging from client to server.
> 
> 
> route -n on server:
> 
> Destination     Gateway         Genmask         Flags Metric Ref    Use
> Iface
> 
> 10.8.0.2        0.0.0.0         255.255.255.255 UH    0      0        0
> tun0
> 
> 172.16.163.0    0.0.0.0         255.255.255.0   U     0      0        0
> vmnet1
> 
> 10.0.0.0        0.0.0.0         255.255.255.0   U     0      0        0
> eth0
> 
> 10.8.0.0        10.8.0.2        255.255.255.0   UG    0      0        0
> tun0
> 
> 172.16.57.0     0.0.0.0         255.255.255.0   U     0      0        0
> vmnet8
> 
> 169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0
> eth0
> 
> 127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
> 
> 0.0.0.0         10.0.0.209      0.0.0.0         UG    0      0        0
> eth0
> 
> 
> 
> openvpn started on server (deleted server name and time stamps):
> 
> when starting openvpn:
> 
> tail -f /var/log/messages
> 
> openvpn[23785]: GID set to nobody
> 
> openvpn[23785]: UID set to nobody
> 
> openvpn[23785]: UDPv4 link local (bound): [undef]:1194
> 
> openvpn[23785]: UDPv4 link remote: [undef]
> 
> openvpn[23785]: MULTI: multi_init called, r=256 v=256
> 
> openvpn[23785]: IFCONFIG POOL: base=10.8.0.4 size=62
> 
> openvpn[23785]: IFCONFIG POOL LIST
> 
> openvpn[23785]: petesuse,10.8.0.4
> 
> openvpn[23785]: petehome,10.8.0.8
> 
> openvpn[23785]: Initialization Sequence Completed
> 
> 
> when Linux client connects:
> 
> 
>  openvpn[20930]: 10.0.0.59:1068 Data Channel Encrypt: Cipher 'BF-CBC'
> initialized with 128 bit key
> 
>  openvpn[20930]: 10.0.0.59:1068 Data Channel Encrypt: Using 160 bit
> message hash 'SHA1' for HMAC authentication
> 
>  openvpn[20930]: 10.0.0.59:1068 Data Channel Decrypt: Cipher 'BF-CBC'
> initialized with 128 bit key
> 
>  openvpn[20930]: 10.0.0.59:1068 Data Channel Decrypt: Using 160 bit
> message hash 'SHA1' for HMAC authentication
> 
>  openvpn[20930]: 10.0.0.59:1068 Control Channel: TLSv1, cipher
> TLSv1/SSLv3 DHE-RSA-AES256-SHA, 1024 bit RSA
> 
>  openvpn[20930]: 10.0.0.59:1068 [petesuse] Peer Connection Initiated
> with 10.0.0.59:1068
> 
>  openvpn[20930]: petesuse/10.0.0.59:1068 MULTI: Learn: 10.8.0.6 ->
> petesuse/10.0.0.59:1068
> 
>  openvpn[20930]: petesuse/10.0.0.59:1068 MULTI: primary virtual IP for
> petesuse/10.0.0.59:1068: 10.8.0.6
> 
>  openvpn[20930]: petesuse/10.0.0.59:1068 PUSH: Received control message:
> 'PUSH_REQUEST'
> 
>  openvpn[20930]: petesuse/10.0.0.59:1068 SENT CONTROL [petesuse]:
> 'PUSH_REPLY,route 10.0.0.0 255.255.255.0,

Is this here pushing a route to 10.0.0.0/24 to the tun interface?

can you verify that you are not pushing this route?

cheers

Erich


____________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users