[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

[Openvpn-users] XP openvpn gui startup problem


  • Subject: [Openvpn-users] XP openvpn gui startup problem
  • From: "Jeff Boyce" <jboyce@xxxxxxxxxxxxxxx>
  • Date: Tue, 20 Mar 2007 10:59:44 -0700

Greetings -

I installed Mathias Sundman's OpenVPN GUI on an XP box for the purposes of
connecting to my office vpn server running on RHEL3.  It installed the
complete package containing OpenVPN and the GUI without any problems, but it
doesn't seem to be running completely.  I am not sure what it is doing so
here are the symptoms that I see.

1.  Right clicking the icon in the tray shows a menu that only includes
three items; exit, about, and proxy settings.
2.  The configuration, certs, and key files are all located in the
C:\Program Files\OpenVPN\config directory.
2a.  An early mistake had the key files in a separate directory, such as
with a linux installation.
3.  The XP box has been rebooted several times since installation.
4.  No log file has been created.  There is a readme.txt file in the log 
directory with a time stamp on the log file
is the time and date of initial installation.
5.  The log file on the openvpn server has no reference to reading the XP 
box configuration file.
6.  All the directories and files appear to be put in the right place during
the installation.
7.  Ipconfig output shows that TAP is installed, but media disconnected.

C:>ipconfig /all
Windows IP Configuration
        Host Name . . . . . . . . . . . . : jeff
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection 2:
        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : 3Com 3C920 Integrated Fast 
Ethernet Controller (3C905C-TX Compatible)
        Physical Address. . . . . . . . . : ab-ac-ad-ae-af-ag (obscured)
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        Autoconfiguration IP Address. . . : 192.168.112.200
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.112.10
        DNS Servers . . . . . . . . . . . : 207.109.192.1
                                            204.147.80.1

Ethernet adapter Local Area Connection 3:
        Media State . . . . . . . . . . . : Media disconnected
        Description . . . . . . . . . . . : TAP-Win32 Adapter V8
        Physical Address. . . . . . . . . : bc-bd-be-bf-bg-bh (obscured, 
different than address above)


My XP client config file is:
remote 333.444.555.666
port 1194
proto udp
dev tun
tls-client
ca C:\Program Files\OpenVPN\config\ca.crt
cert C:\Program Files\OpenVPN\config\JABlaptopclient.crt
key C:\Program Files\OpenVPN\config\JABlaptopclient.key
# ns-cert-type server
resolv-retry infinite
pull
nobind
persist-key
persist-tun
comp-lzo
verb 3

My Linux server config file is:
local 192.168.112.1
port 1194
proto udp
dev tun
tls-server
ca /etc/openvpn/easy-rsa/keys/ca.crt
cert /etc/openvpn/easy-rsa/keys/BisonVPNserver.crt
key /etc/openvpn/easy-rsa/keys/BisonVPNserver.key
dh /etc/openvpn/easy-rsa/keys/dh2048.pem
server 10.8.6.0 255.255.255.0
float
ifconfig-pool-persist /etc/openvpn/ipp.txt 120
push "route 192.168.112.0 255.255.255.0"
keepalive 10 120
comp-lzo
user nobody
group nobody
persist-key
persist-tun
status /var/log/openvpn-status.log
log-append /var/log/openvpn.log
verb 4

I have read through all the How-To's and Read-Me's and have not seen 
anything like this posted in the list archive.  Does anyone have a clue as 
to what might be going on here?  Thanks for any information you can provide.

Jeff Boyce
www.meridianenv.com

______________________
OpenVPN mailing lists
https://lists.sourceforge.net/lists/listinfo/openvpn-users