[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] Compatability question


  • Subject: Re: [Openvpn-users] Compatability question
  • From: Mathias Sundman <mathias@xxxxxxxxxx>
  • Date: Mon, 16 Oct 2006 10:43:47 +0200 (CEST)

On Fri, 13 Oct 2006, Tony Molloy wrote:

> I'm running openvpn-2.1_beta15-1 on linux as the server with "topology
> subnet" option set. I can connect to this with a linux client also
> running openvpn-2.1_beta15-1.
>
> However I have a client who wants to connect using windows so he installed
> Mathias Sundman's GUI package. This has openvpn-2.0.7. So my first
> question is is 2.0.7 compatible with "topology subnet" and if not what
> can I do other than get him to use a later version.

Only the 2.1-xx version of OpenVPN supports topoloty subnet AFAIK so you 
only have two options

a) Don't use topology subnet
b) Tell your client to use 2.1 instead.

Even though I havn't created any installation packages with 2.1 and my GUI 
you can easily install OpenVPN 2.1 with James installation package and 
then simply download the OpenVPN GUI binary and use it together with 
OpenVPN 2.1.

Or, if you prefer to only run installation packages, begin with installing 
my OpenVPN-GUI installation package with OpenVPN 2.0.7, then run the 
OpenVPN 2.1-xx installation package to overwrite the OpenVPN installation.

-- 
_____________________________________________________________
Mathias Sundman                  (^)   ASCII Ribbon Campaign
OpenVPN GUI for Windows           X    NO HTML/RTF in e-mail
http://openvpn.se/               / \   NO Word docs in e-mail
______________________
OpenVPN mailing lists
https://lists.sourceforge.net/lists/listinfo/openvpn-users